2 FAT32-formatted Elements 2tb USB drives - can't mount both at the same time


#1

Have (2) Elements 2tb USB external drives. Both have been changed to FAT32 format with Disk Utility per the instructions in the WD Knowledge Base, one as GUID Partition Table, and the other as Master Boot Record.

Either will mount successfully and function correctly alone, but when both are attached (one to each USB port), only one will mount/can be mounted at a time.  The other does not mount/appear in the Finder.

The other _does_ appear in Mac OS’s Disk Utility as “WD Ext HDD 1021 Media” (same for both), but the icon under it (which has the name I gave it) is grayed out and does not respond to the Mount button.

FYI:

  • Mac OS 10.4.11 (Tiger)

  • both USB ports work fine - I’m pretty sure they’re not the problem.

  • I also have a 640gb Passport USB bus-powered drive, and I have had similar problems mounting it and either 2TB at the same time, although it worked fine the last few times I tried it.

  • I have a 500gb My Book USB external that has always mounted fine simultaneously with the 640gb and the 2TBs.

I have tried restarting several times, and various orders of USB and power connection.

I really need to be able to mount both 2TB drives at the same time reliably.  

Thanks to you all for any suggestions you can offer,

Kevin