2.5" SATA Board + CM3 + SSD

From what I have read in the forums it looks like the 2.5" Sata Board is not working with the CM3 and a 2.5" SSD drive? Is that the case> I just spent a small fortune on all the parts hoping to put together a nice little file/docker server for various projects. I would be gutted if it is not going to work.

The SSD does not seem to be detected properly and I am getting the following messages from dmesg:

[  184.036181] sd 0:0:0:0: timing out command, waited 180s
[  364.046177] sd 0:0:0:0: timing out command, waited 180s
[  544.066178] sd 0:0:0:0: timing out command, waited 180s
[  544.066251] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x00 driverbyte=0x08
[  544.066272] sd 0:0:0:0: [sda] Sense Key : 0x4 [current] 
[  544.066288] sd 0:0:0:0: [sda] ASC=0x30 <<vendor>>ASCQ=0x85 
[  724.076175] sd 0:0:0:0: timing out command, waited 180s
[  724.076245] sd 0:0:0:0: [sda] Test WP failed, assume Write Enabled
[  904.086186] sd 0:0:0:0: timing out command, waited 180s
[  904.086256] sd 0:0:0:0: [sda] Asking for cache data failed
[  904.086275] sd 0:0:0:0: [sda] Assuming drive cache: write through
[  904.093563] sd 0:0:0:0: [sda] Unit Not Ready
[  904.093592] sd 0:0:0:0: [sda] Sense Key : 0x4 [current] 
[  904.093608] sd 0:0:0:0: [sda] ASC=0x30 <<vendor>>ASCQ=0x85 
[ 1084.106177] sd 0:0:0:0: timing out command, waited 180s
[ 1264.116227] sd 0:0:0:0: timing out command, waited 180s

I am using the official RPi3 power supply which has plenty of juice - it is my highest rated power supply. Is there anything I can do to get this working?


Hi, thanks for bringing your issue to the forum. The WDLabs SATA adapter board does work with CM3 and SATA SSD’s (at least on the SanDisk SSD Plus, which is what we’ve been focusing on).

Some questions to start debugging:
Are you booting from the CM3’s eMMC or trying the R-Pi.org’s MSD boot feature?
What OS/software are you running?
Do you have max_usb_current=1 in config.txt?


Thanks for the speedy reply.

  • I am booting from eMMC
  • I am running Rasbian Lite
  • I have not set the max_usb_current

I am guessing I should try the max_usb_current? It feels like it could be power related.

I gave the max_usb_current setting a quick try and I am not noticing any improvements. I still see the time out messages in dmesg and shut it off before more errors.

Hi, have you tried a SATA HDD?
Is the OS running only on the eMMC, or are you trying to run root directory on the SSD?


@dwcsjca not tried a standard SATA drive, unfortunately I do not have one of those to hand. The OS is fully installed to the eMMC, I am really interested in just the using the drive as storage and keeping the OS expendable on the eMMC. Let me know if you would like me to try anything.