2.06.10 powers off device


WD Live Hub was turned on and a new update was available in the home main menu. I didn’t notice what it was but went ahead and downloaded, installed and rebooted back to the home main menu. Another new update was available. This time I saw firmware Version 2.06.10 and it was downloaded, installed and rebooted.

Now when turned on the device’s ‘WD’ blinks then after a longer than usual delay ‘WD’ appears on the TV screen with the ‘Loading …’ text below but then it shuts off. No home main menu appears and Windows7 is unable to access the drive (default Z).

I tried simply rebooting a few times and then unplugging the power for 10 minutes but no luck. Next tried to rollback the driver but the device won’t stay on long enough to access the home main menu to do this. Also tried the reset button but again it won’t stay on long enough. I discovered the power button on the device doesn’t work.

Have searched the WD forums … sorry if I missed this one.

Great device! Suggestions are appreciated, thanks. Len

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support


I have a very similar problem, although mine will actually get past the boot up phase. I was previously on 2.05.08, and updated to 2.06.10 a couple of days ago. I’ve timed it at least ten different times, and the unit will stay powered for anywhere between 5-15 minutes before powering itself ever since the 2.06.10 update. This problem absolutely did not happen prior to taking the 2.06.10 update.

It doesn’t appear to be related to anything I’m doing on the WD at the time it powers off. One time I was playing a video directly off of the onboard hard drive, and after about 7 minutes of play the unit turned off. Another time I was streaming media to another device off of the wdtv live hub, and the media/content became unavailable after playing for about 11 minutes (the wd had shut itself off again). Another time I left it booted into the main menu screen, and did nothing. At about 14m20s after starting, it shut off while simply sitting at the menu.

I opened a support case with WD. They had me reset the device to factory default settings, but that didn’t help. Then they directed me to the following URL, which provides older code revisions to download, extract to the root directory of a USB device, and plugin to the unit. This let me downgrade to the last known good revision of code I was running - 2.05.08 (although when I took the update via USB, it said ver 3.05.08 – I suspect to trick it into thinking its an “upgrade” as the revision number is higher, even though the code is older?).

Now I’m on 2.05.08 and the spontaneous power off problem persists, when it never did before on 2.05.08.

I will note that when I first tried to apply the new 2.06.10 firmware, it appeared to get through the 2 stage update process (you’ll see a percentage complete bar for 1/2 and then 2/2). However when it automatically rebooted itself, it was still on 2.05.08 code, telling me there was another update available. I applied the update a second time, and it took (most notably adding a games option to the main menu, and a picasa widget/app addition).

So I’m not sure if some sort of file/nvram/block corruption happened during the update process, but it has been broken ever since, even after rolling back to known good revisions of code.

I plan on calling WD support back again tonight after work to see if they have any other ideas, but the last support rep I spoke to led me to believe the next step was issuing an RMA to get a new unit, which does not particularly sit well with me considering I have nearly 1tb of data on it with nowhere to temporarily store it :confused:

Anyone else run into a similar situation and found a way to resolve the spontaneous shutdowns?


Noticing a handful of threads more or less reporting this same symptom.

Could a mod possibly merge these threads and make one for everybody to follow (and perhaps sticky it at the top? I suspect there will be more users flocking to this forum looking for answers about this new issue).

This is a legit problem that has surfaced with the latest code (2.06.10)

I’ve contacted WD support via knowledge-base and it’s down tonight. It needs to be fixed and I’m sure they’re working on it. A response to a user defined solution would be nice even if to let us know. Mine’s just sitting by my desk waiting to be fixed here by me or shipped to WD. I have data I can’t access either.

I had a similar issue with my Hub but I assumed it wasn’t a firmware issue, as I never updated past 2.03.24.

I turned my hub on, and it spontaneously shut down after about 10 minutes. The next time I turned it on it shut down while at the main “Loading” screen. Every time I tried to turn it on, it would blink for 10-20 seconds then shut itself off. It wouldn’t even let me push the power button manually to turn it back on. I called WD and spent around an hour on the phone with them going through every possible scenario that could have caused the problem. We came to the conclusion that it was a hardware issue because I hadn’t touched the firmware in months. My replacement hub is coming tomorrow but seeing this thread today makes me worried that there is a much bigger issue going on here than faulty hardware in my particular unit.

Thanks for that input. You’re experiencing the same issue but not firmware related. It’s coincidence that a few of use experience this the same time as firmware upgrade. Will give it the weekend and hope for some mod input before contacting WD. Cheers

WD issued an advanced replacement for me yesteday, so I’ll get a new unit first and will have 30 days to attempt to copy all of my media to it from my current device that won’t stay powered for long (that’ll be fun!!) before I need to ship the old one back.

If a WD dev reads these forums, I would be more than happy to give remote access to my LAN if there are any diagnostics that can be run to help isolate the spontaneous power off/crashes. The more data collected about corner case problems like this now, the better off we’ll all be for future firmware flashes so these pesky things don’t resurface :slight_smile:

I too needed to send in my unit for warranty service because of the firmware update. However, I chose standard warranty service.

The unit keep getting progressively worse each day until it immediately turned off, plus I could hear the hard drive clicking away. Just after updating to 2.06.10 everything worked fine for a few days and then suddenly during a video I lost connection to the unit over the lan. Now, it would not boot to the ‘home screen’ at all.

Setting up the RMA went extremely smooth. I expect the exchange to go just as smooth.

xcbikeman, check and see if your cooling fan is spinning on the bottom when you power your device on… mine has stopped spinning after the upgrade and appears to be overheating and shutting off.

For more info see my post in this thread:  WD-TV-Live-HUB-freezes-after-some-time-of-playing-videos

The fan is not necessarily going to spin up when you power on.

The fan is thermostatically controlled.  

If there are heat issues, the UI is supposed to put a warning on the screen before it shuts down.

Ahh, good to know. Thanks!

My fan on the old unit is never turning itself on, and the fan on my new unit is always on fwiw…

WD support contacted me last week and instructed to create an RMA. The support staff stated it was a coincidence that the firmware and powering issue occurred at the same time. I originally chose WD as a media player AND storage device based upon previous WD reliability. Have done some snooping around and it seems that stand-alone/portable HD’s maybe haven’t quite come into their own yet. Think I’ll go with an extra internal drive for large storage back-up/storage.

In your signature, you say “I screwed up and put .co for email extension during sign-up.”.

Why do we need to know that?  Just ask WD to fix it by PM’ing bill_s.

“When turned on the device’s ‘WD’ blinks then after a longer than usual delay ‘WD’ appears on the TV screen with the ‘Loading …’ text below but then it shuts off”  this is my problem and after 2.06.10

Laurentiu. Same problem here. Support via Knowledge Base email/messaging stated it was a coincidence… it’s a hardware not a firmware issue. I initiated an RMA this morning through the Warranty page. Cheers.

I got my unit back from WD today. I received a brand new retail unit. (Way to go WD). I immediately updated to the 2.06.10 firmware and everything went fairly smooth. I did have to request it to update twice to 2.06.10. After downloading 2.06.10 the first time, the unit rebooted, but did not update. This is exactly the same issue I had on my previous unit just before it quit booting to the OSD. So, I proceeded to update again and the update completed.

I just finished playing a game of Sudoku. I am going to wait a few day before loading any media on the unit. On my last unit, it was only a few days after updating to 2.06.10 that I started experiencing problems.

Thus, if you never hear from me again assume my unit is working fantastically. If not, like ex-Governor Swarch-something…I will be back.

As it says in the release notes, “If upgrading online from firmware less than 2.05.08, the online update will automatically update to 2.05.08 before upgrading to the currently released firmware.  ”

Out of the box it was probably running 2.02.16, so what you saw is correct.

This all sounds like the POWER switch problem, to me. No wonder they had you RMA the unit.