2.02.32 Firmware show "name of movie".mp4 on the title

until this latest update the player would on show “Movie name and date”. Now only my mp4 movies are renaming theirselves. Very annoying and it needs to be fixed. i have already deleted the WD folder 50 times delete the new **bleep** hidden folders for this ratings system that can’t be turned off… this update so far i have’n’t had any issues as far as it not playing anything. but i hate seeing the file type…

anyone else having this issue?


Have you tried to select the option “get Info” on these files?

Yes , and it still shows the “name of the movie” but removes my date … which is annoying… i use WDHUBGEN on every file before adding it . all the player has to do is read it.

just a guess ?  have you turned the Get Content to “Manual” ?  after the firmware update it most probably defaulted back to “Auto”

Setup > System > Get Content Info > Manual

not sure if this is the problem?

(also, MP4’s can contain embedded metadata … so, no matter what you name the file … the WDTV will display the metadata “Title” and not the “Filename” … use mp3tag to see if they have embedded metadata.    http://www.mp3tag.de/en/  )

Anyways, that’s all i can think of

thanks im aware of the embed metadata . but this issue is only with the latest firmware . if i roll back to any other firmware this problem goes away…

worked out what’s happening

Edge of Tomorrow (2014).jpg

Edge of Tomorrow (2014).mp4

Edge of Tomorrow (2014).xml

look inside the xml (use notepad)

You need to edit the “title” in the XML to display your file name with the date.

from    Edge of Tomorrow

to     Edge of Tomorrow (2014)

Some views will display the file extension some won’t   (mp4)


1 Like

Yes exactly , it is very annoying considering it has only been a problem since the latest firmware . i like the new rotten tomatoes ratings and all … but some reason it will read the meta now in some movies and reading all mp4 as you have demostrated!

I have to much time and effort in collection and i feel this is unexceptable.