1TB WD passport not working inaccessible

 1TB WD passport not working and inaccessible. I just bought the HDD a day before because my my previous HDD was showing SMART error and after I am done with copying the data to the WD passport it was working fine for 12 hours. There after when I plugged the device to my system it just shows a new drive with no information and data in it. Neither did this HDD show up in the windows disk manager. It was all the data from years of effort. I was frustrated. Then I tried reading the data through Acronis true image home bootable CD and hurray !! The drive was shown there with all the data. I took a back of the all the data to another disk and pledged not to buy WD again in my life. WD **bleep** !!

Did you ever try the disk on another pc?  Or did you just boot up with Acronis on the same pc, and then the drive showed up?  Also, did you run any diagnostics on the drive to see if there was anything wrong with the drive?  Sometimes a passport drive won’t show up if it’s not getting enough power from the USB port it’s connected to.

Okay, I got mine to work - I plugged it into the USB port on the front of the computer and it came to life. Don’t know why it worked but it did!  Might be a bad USB port.