1TB WD My Book World II (Blue Rings) not working

Hello all,

My 1TB WD My Book ( http://www.imagebam.com/image/9f4755294422177 )  is not working and every time I plug in the USB, it shows this popup window:

You need to format the disk in drive G: before you can use it

It’s not even showing the free and total size in Computer and when I click on it, it shows:

G:\ is not accessible

 

The file or directory is corrupted and unreadable

this is a chkdsk screenshot

http://www.imagebam.com/image/f4a1c9294422181

system used: Windows 7 64-bit

disk Format : NTFS

I have tried the following:

1- uninstalling the drivers from Device Management" and restarting my laptop

2- downloading/installing the MY BOOK drivers from WD

3- downloading/re-installing my laptops USB drivers

4- plugging the USB in all the 4 ports (one is USB 3.0)

5- turning on and off the external by pressing the button

6- plugging and unplugging the A/C power

I can try this solution as a last resort, but I’m not sure what to do afterwards.

 

Please help a brother out. I need my files back :’(

 

iSari,

Unfortunately, dismantling the device may not address the issue as this appears to be data corruption (Either logical or physical). I would recommend trying with data recovery utilities available in the internet.

Thanks JStaff

what free but helpful software should I use?

I want to take it out and transfer my files to my new MyPassport Ultra external

iSari wrote:

Thanks JStaff

 

what free but helpful software should I use?

 

I want to take it out and transfer my files to my new MyPassport Ultra external

Don’t expect for wd personal here to name 3rd party software.

Try MiniTool.

3rd party software _ GetDataBack _ solved my problem

1 Like