1TB WD My Book is "not mounted"

Can someone help me?

I tried to access to my ext HD for Mac but I dont see its icon (it is missing).  

I vaguely remember that few months agoI deleted the icon in order to stop backing up(I guess it was a supid move, but I coudn’t think of any other way at that time).

Now I dont know how to access the ext HD.

I opened Disk Utility and I see the icon in the left column, but it is in the gray letters (= cant open).  

It says the ext HD is not mounted.

I tried to “mount” the disk and failed to do so.

When I “Verify” and “Repair” the disk, the result is OK.

While not knowing what to do I downloaded the Drive Manager, thinking it might lead to resolving the problem.  It didnt make a difference.

Thank you for your help!!

Hi and welcome to the WD community.

As a troubleshooting step, try using another USB port to connect the My Book and connect the power cable directly to a power socket. 

I tried it and got the same result :cry:

Do you have any other suggestion?