1TB USB drive, 3 clicks times then nothing


Got this drive in 2012, in NZ, 1TB USB PASSPORT - not sure what the following name is, because WD do change their names often.

Written on the outside of the black inclosure :
P/N - wdbbep0010bbk-03
[Removed - Trancer]

On drive inside the inclosure :
1.0 TB WD10jmvm - 11s5xs1
[Removed - Trancer]

Formatted it to ext4, linux, used it happily since on my Debian machines. Mounted it on a Raspberry Pi2 the other day, where it worked just fine. Rebooted the Pi2 and then the drive didn’t mount.

It just light and spin up, blinks about 15 times while it clicks 3 times loudly, spins down with the light on constant. After a while it spins up again and do the same blinking/clinking but stays spinning.

I have tried it on on USB 2 and 3 on a Debian laptop and a win8.1 laptop. Both places the same.

Win8.1 mounts it as “WD Passport 07A8” and I can eject the drive when in the USB2 port. When in the USB3 port it comes up with “My PASSPORT” and the icon change to a image of the passport.

Using DiskInternals Linux Reader or Ext2Fsd just send the drive into a clinking and spin up/down frenzy.

So is this drive a paperweight or is there a way to CPR?



Try getting the information out of the drive and try to reformat the unit again to see if it shows up.

ah, that is why I’m asking here, what to do?

on the debian laptop - it just clicks and spins down, no chance of mounting it.
one the win8.1 laptop - win says there is a disk, but clicking on the icon, nothing happens. When trying the utilities for reading ext4 drives on winOS, the drive spins up and clicks like no tomorrow.

On neither laptop I can get to a position where I can see the content of the drive.


3 loud clicks followed by a spin down would indicate that your passport drive has a head failure. This is not something that WD would recover for you, nor it is a DIY type of issue to solve. Problem is mechanical and related to the internal head disk assembly. You should be looking for a data recovery specialist for data recovery services if data is important.

Thanks nothing lost on the drive got copies elsewhere, what just hoping that there was a trick to get it back online. Will use it as a paperweight now.

I see, drive is paperweight then

but this is what would need to be done in order to get it to a point where it can read again