drive shows up but

I can see under network drives.  But then when I get out of the setup program it vanishes.  Then there is no assigned drive or network drive left to use at all.  Can not get a drive to stay on the computer. This is also a wi-fi computer or wireless whatever you want to call it.  All wireless printers work and other computers work on the network.   HELP  WHAT IS UP WITH THAT.

My other computer is fine and the drive was assigned properly and is in use with no problems.  Yes the network is working just fine as this can be seen by the use of the other computer.

I keep trying different things but nothing seems to work in getting this computer to wirelessly connect to the WD Drive.  So I guess my next step monday is to call tech support.  I tried on friday but got a no body who new nothing to help.  Once more then it going to be for Seagate setup and back goes WD.  Wireless is the furture and this seems not to be for the now computer hook ups.

Try mapping the MBL manually, chk the link bellow.


We tried that, the problem was with, I needed to update the software.  But when you see all those warnings about loosing data it makes you very doughtful about doing so.  but it was the answer.