11 month old My Book Essential 2TB USB3.0 drive not working

Up until 2 weeks ago it worked perfectly, then all of a sudden it would cut out. Turning it off and on again - though annoying - seemed to do the trick. For a while I had to tilt the unit to keep it connected as the usb3 port on the back was loose-fitting at best, but now it’s my newest paperweight.

When I plug the power cable into the mains, the power light on the drive comes on and for up to half a minute the drive will whirr and you can hear the disk clicking as it spins round.**  An “installing device driver software” bubble pops up on my screen and while the USB Mass Storage Device is classed as “ready to use”, the WD My Book 1130 USB Device gets stuck on “searching preconfigured folders”. Then the power cuts out. Then the drive turns on again. This cycle starts again 3/4 times before it gives up completely, though the power light remains on at all times. I’ve tried different cables/ computers. No luck.

**Incidentally, you can hear that something has come loose and is rattling around inside if you pick the drive up, but I have no idea how to remove the casing to check what that something is & don’t want to void my warranty unnecessarily by damaging it.

[edit:] Having left the Disk Management window open for about 10 mins now, it just popped up with Disk 2 (the drive it can’t find). There’s a red, downward pointing arrow on top of the drive’s icon and underneath it says:



Not Initialized

[edit2:] Right-clicking on that to initialize the drive did not work. After ~15 mins, a window popped up saying:

“The device is not ready.”

Any thoughts/help/suggestions on what to do next?

I assume it’s something to do with the physical connections themselves, but really have no clue :\

(thanks in advance)

Not much hope here, I suggest you to contact WD for a replacement.