1 TB WD Elements SE is not detected :(

When I connected my 1 TB WD Elements SE yesterday a message popped up with “Your USB Device is not recognised…”, so I disconnected it and connected it again it worked for about 2 minutes and disconnected completely. I thought it was the cable so I tried a new working cable but it’s not detected although the HDD is spinning normally and it connects rarely for 2 or 3 minutes and disconnects again. I guess it’s the USB port in the HDD. Is there any way to repair it or recover my data :frowning:


I recommend that you try on another computer if possible to verify if the issue remains.

WD does not repair or recommend repair services for our hard drives. Please note that any repair services performed on a WD drive will void the warranty.

How to recover data on a drive, obtain a circuit board, repair a drive, or find a list of WD data recovery partners 

I’ve already tried it on 4 computers, I think it’s the USB port of the HDD, it’s somewhat loose :confused: this drive is still under warranty, so what is the possible solution for bringing it back to life again??


Trying to repair the drive will void the warranty. 

I recommend you get a RMA on this.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty