1.5 tb black is now reading 500 gb

Ok, here’s the situation.  I bought a 1.5 tb black to replace my 1 tb green in my desktop.  I have a SSD 120 intel as my OS and programs and all files and everything else on the 1 tb green.  Computer specs:

ASUS P5K0E/WIFI-AP LGA 775 Intel P35 ATX

Kentsfield CPU

6 gbs of ram, 2 - 1 gbs of G Skill DDR2 don’t know the speed offhand and 2 - 2 gbs of G Skill PC2-6400 DDR2

Antec True Power Trio TP3-550 ATX 12V 550W

Samsung 20x DVD-+R DVD burner with lightscribe

Cooler Master RC-690 KKN1-GP black secc/abs atx mid tower

SAPPHIRE 100297L Radeon HD 5830 1GB 256-bit

Windows 7 professional 64 bit

At any rate, this is what I did.  I turned off my computer, unplugged it from the back, opened up the computer, added the new hard drive with an open sata port and power port.  I booted up the computer and the drive was there.  I opened up computer management and added it properly and did a quick format.  I went to my computer and it was there reading at 1.5 tb.  I was stoked.  I started to copy all my d over to the new drive which was labled B at the time.  Everything worked and I powered down the computer and unplugged and took out the 1 tb.  I booted the computer up and the disk was not readable and it wanted me to format the drive as a 500gb drive!  I was like bleep?!  So I put back my green 1tb and took out my 1.5 tb and put it in an external and it still read as a 500gb.  I brought it to my work and tried to format it and it still only read as a 500gb.  I had it rma’d and thought it was a one time deal.

I got my new drive.  This time I put it in an external enclosure first.  It booted fine and I formated to 1.5 tb.  I then copied all my files over to the new drive and rebooted again and everything was fine.  I changed the letter from B to D and it was still fine.  I then disconnected my green 1tb and turned my computer on and again . . . 1.5 tb gone and it was replaced by a 500gb uninitiated drive . . . again, bleep?!  I talked to WD support and then said to do a zero 1 format.  I tried, but it failed after 30 minutes.  Rma’d again . . .

I got another new drive.  This time I put it in my desktop, formated it, copied only 30 gbs of stuff, changed the drive to D, changed my green to E and then rebooted.  I was cool, so I shut down the computer, removed the E, which is my green 1tb and then rebooted . . . and yes, it’s Groundhog Day!  I am going to rma this thing again, but has anybody in this world ever had or seen this problem?

Just to be clear, I had my paging file on my  D (green 1tb), changed it to the new drive and then rebooted until the black 1.5 tb had the paging file on it and the green 1tb was clean.  Please for the love of God, help!  I will be rma’ing this one last time, but I am truly at a loss of words.

Dean

Oh and the western digital data lifeguard diagnostics tools can not even read the drive.  It sees it in the logical drive list, but doesn’t see it in the physical drive list where you can run tests . . .

I see this problem at least once a week, but in those cases it involves a Gigabyte motherboard with an Xpress Recovery BIOS. Gigabyte’s BIOS has a bug that incorrectly truncates the drive after the BIOS writes a backup of itself to a HPA.

See this thread for an explanation and solution:
http://forum.hddguru.com/lost-partition-hitachi-1gb-hdt721010sla360-t15662.html

The BIOS only looks at the first drive in the boot order. All is OK when the 1.5TB drive is second in the order. However, when you remove the 1TB drive, the 1.5TB is promoted to first. That’s when the damage is done.

I’m not sure that the above scenario also applies to Asus boards, but the symptoms are very similar.

BTW, in Gigabyte’s case, after the drive is restored to its original size, it is effectively immune to further damage. This is because BIOS sees that its backup copy already exists on the drive.

So should I remove my 1 tb green drive first and then install the 1.5 tb as it will read as the first drive and then just add my 1 tb as an external and then copy my files over?  If that’s the case, then I’m totally good with that, because this is just freakin’ ridiculous at this point, if you know what I mean!  Thanks and I will rma and then try that out!  Peace.

Dean

Please don’t RMA your drive … again. The drive is NOT the problem, and it is NOT broken.

In any case, you have misunderstood my explanation. You need to attach the 1.5TB drive as a secondary drive, boot from the 1TB, and then run the HDD Capacity Restore Tool to restore the drive’s original size.

If the tool doesn’t work (because of a Windows issue), then create a bootable version of HDAT2 and use it to restore the drive’s full native capcity.

To “change the native size” of your HDD, see page 5 of the HDAT2 user guide:
http://www.hdat2.com/files/cookbook_v11.pdf

Got it, understood.  I will try that later this weekend and hopefully be up and running.  The one problem I have with my 1tb doesn’t have an OS, my SSD 120 has the OS, so to make things clear, I need to leave my OS in, attach my 1.5 tb as my secondary drive, remove my 1 tb and then run the HDD Capacity Restore Tool.  If that doesn’t work, then I need to use the HDAT2 version which is a bootable version.  So if the first method works, the 1.5 tb should not have a problem after rebooting and even if I attached my old 1 tb, right?  Thanks for all the help!

Dean

Sorry, it appears that I’m not a very good communicator.

The order of the 1.5TB drive is now irrelevant. All you need to do is to boot to any Windows drive, install the HDD Capacity Restore Tool, and then run it against your 1.5 TB drive. Then reboot.

HDAT2 is probably the better option because it doesn’t rely on Windows. It’s also a very powerful tool which I’m sure you’ll like very much. IMHO it should be in everyone’s toolbox.

Having said the above, I have only heard of this problem in Gigabyte motherboards, so it’s possible that there may be something different about your particular setup. Therefore I suggest that after you have restored your drive to its full size, you should scan it backwards using a disc editor and look for BIOS related text strings. This will confirm whether BIOS was responsible for the damage. If you need help with this, let me know.

DMDE (DM Disk Editor and Data Recovery Software):
http://softdm.com/download.html

Hi,

Thanks for the information.  I tried using the windows version with no luck, so I tried the bootable ISO of Hdat2.  It’s a little complicated, but I was able to get into the drive and then remove the hidden areas, which I thought would work, but when I booted to windows, there was an 800gb partition, a 200gb partition and another 800 and 200 . . . I was totally confused, so I went back into the hdat2 and did a remove hidden area and it worked, but decided to wipe the drive, which is running right now.  I will let you know what happens next.  This is so confusing!

Dean

Well, it worked brotha, it worked.  I removed the other partitions and the drive read back to the 1.5tb.  I will install in my computer at home and see if it stays that way.  Here’s crossing my fingers.  I’m going to update the bios of my system so hopefully it will correct any other issues it may have.  Thanks again!  Btw, once I remove the hidden areas, they won’t come back again, will they?  I guess I just have to install and see . . .  I will let you know in the next day or so.

Dean

Congratulations and thanks for the feedback. It appears that this bug affects both Asus and Gigabyte BIOS. However AFAICT Asus uses AMIBIOS whereas Gigabyte uses Award. I’m not certain about this though.

Removing the HPA won’t affect whatever data were written to that area of the drive, so hopefully BIOS will see its own copy and refrain from touching your drive again.

You could search for BIOS related text strings at the end of your drive using DMDE.

Choose your Physical Drive

Select Mode -> Hexadecimal

Type Ctrl-End to go to the last sector of the drive.

Select Tools -> Search String in Object

Type your desired text into the Text box, eg BIOS, AMI, American Megatrends, Award, Phoenix, etc

Select the Backward and From Cursor radio buttons and click OK.