Yet another possible solution to not seeing the media shares


#1

This write-up refers to problems I experienced with windows 7, 64 bit home edition. I described this in previous posts but I will do it again so as not to create confusion.

I had trouble seeing my music library in media shares while the movie library and picture library where fine at all times. The music media shares library  was visible at times and gone some other times. I was also experiencing interruptions while playing songs. The folders with movies and music the media library refers to are located on a separate Seagate USB external hard-drive while the picture folder is on the main hard-drive of my computer. I would have probably noticed this earlier had my music library not been so messy, i.e., the whole 61 gigabytes of it resides in a subfolder of a subfolder of another subfolder etc… You get the picture.

The music library was correctly pointing out the location of the music files yet, more often than not, I was getting “no media found in this folder” message. The problem was one of the  upper hierarchy folders , second from the main folder, down the line, and I never looked at that folder  because I was always going straight to the folder where the music is organized in subfolders with artist names, just like an I-tunes library but buried in layers of folders/subfolders.

So, that upper echelon folder had a lock on it which I have overseen. I knew I found the problem because that folder could not be shared so when the WDTVLIVE was trying to go down to the last folder, it was getting stuck there. I went ahead trying to share that folder and I could not, because its ownership was taken by somebody else other than me, although I was logged in as administrator.

If I right click that folder, go to properties and then the click on security tab, I could see that in the list of  groups and user names, other than usual administrator, everyone, guest, blah, blah, blah, there was one name that looked something like this:

S-1-5-21-1454471165-1284227242-725345543-1003

that user had administrator rights and a red ? next to it.  If I click on the Edit button right below that box, another window opens with the same list but with Add and Remove buttons under it. In my case, those buttons were not enabled so I could not remove that account in that window even if I wanted to.

Where that name comes from, I don’t know, maybe experts could chime in here, but, to digress, that name had taken administrator rights of the folder and there was nothing I could do about it.

To remove that though, I figured  I had to go back to the Security tab in the properties windows of that folder and click the Advanced button, Owner tab. Only in that window it would say that the owner of the folder was the long name mentioned above, in the Current Owner box.

Underneath that there is also a box with “Change owner to” options and one of the names listed there should be that of the administrator, i.e., you.  Click the “Edit” button which will take you to an identical screen where you can change the ownership. Highlight your name in the “change owner to” box and click “Apply”. That will give you a warning window that tells you that you are the owner of the folder now and after OK-ing that you’re taken back to the previous window where your name would be confirmed as the owner. Click “OK”  again and that will take you back to the Properties/Security tab window where you click again on “edit” and now you will be in the window where Add/Remove buttons will be enabled and there, you highlight the weird name and click “Remove” .

 Go back to the “Sharing” tab of the properties window of that folder, click on the “Share” button and make sure that “Everyone” is on the list and now you’re done. The lock should be gone from the icon of that particular folder.

Weird thing is that, in my case, removing the lock from the upper echelon folder made the lock move down one folder so I repeated the procedure above until I got to the folder where the “Artists” folders are located. I was holding my breath because I thought the lock will propagate to all these folders and then I would have to go one by one and remove those locks, gargantuan task in my case. Fortunately, the lock propagated to only 5 or 6 of them, the rest were share free. Why to only a few and not all of them, I have no clue.

Another thing I noticed: when going to “Properties” -> “Security” tab -> “Edit”. Even if the “Add” “Remove” buttons are enabled there without changing the ownership, and you can erase the user name there the first time around, the ownership of that folder is still taken by that unknown user so you still have to go to “Advanced” and replace the ownership per above.

Now, I don’t know where the unknown user is coming from in my case, truth is that I upgraded my computer from vista 64 to windows 7 64 few months ago and maybe the phantom username comes from that process, but if you see the little red ? next to a weird long name or “Unknown User Name” in the list of authorized accounts, that might be where your problem is and maybe you should try removing it.  

Sorry for the long instructions, hope this helps. It made sense to me after almost one month of screwing around with settings on my computer and following many procedures good people on this forum were kind enough to post for the rest of us, which, by the way, helped me in getting to this point.


#2

That long string that you mention S-1-5-21-… is nothing but the secure identifier (SID) of a user account. All the users you create in a windows environment get one, but normally the system shows you the username that corresponds to it. When the OS can’t find any local user on the PC that matches the SID attached to the file, then it shows you the SID instead. Think of it like a social security number that doesn’t match the identity of any real person anymore. You probably created it from a former windows installation, or you have a dual boot and did it from there.

Btw after you took ownership of that folder, you didn’t need to go down one subfolder at a time. By default, permissions are inherited from parent to child subfolders, and if for any reason the permissions get screwed along the way, you can always clean up the permissions of all subfolders and items hanging from it, and force them to inherit again the permissions of the parent folder. You only need to go to that folder, and on the security tab click on “advanced options”, then “change permissions”. After you are happy with the permissions you want to spread to the subfolders you can just click “replace permissions of all child objects with entries inherited from this folder” or something along those lines, I have a localized version of windows.

This is nothing out of the ordinary btw, a lot of people don’t care much about the permissions of the file system, or simply don’t wanna mess around with it because it seems a little arcane for a lot of people. In practice many PC’s of home users are ridden with orphan SIDs, bogus sets of permissions and whatnot, and that ofc leads to strange problems and security holes. And ofc it can lead to being locked out of the files from the WDTV live.


#3

Make sense.

After digging some more, that unknown user id was showing up in other lists of authorized users for the picture folder and the movie folder but it was not the owner of that folder. Question is, who should be the owner, in the picture folder I had Administrator as the name of the owner, in the movie folder I had my login name as the owner of the folder, I guess it doesn’t make a difference.

Another thing, even if you remove the unknown user id, it seems that it makes its way back on the list somehow the next time you turn the computer on or log back in. Do you know how to get read of it for good as it seems that it  could be taking ownership of objects at times.


#4

Well I can’t tell for sure since I don’t know what happens around that PC, but I know what I’d try to fix it. However you need to be careful here, if you do things carelessly you can screw things up:

1)  go to the root directory of the partition you wanna clean from bogus permissions, e.g.  f:  Open the security tab and go to the “advanced options” button, and then to “change permissions”. There you’ll see the set of permissions that are gonna be inherited by all the files/folders stored in that drive. Depending on the OS used to create that partition etc… it might look a bit different, but a reasonable set of permissions would be somewhat close to this:

  • Full access for the Administrators group

  • Full access for System

  • Read/modify access for the Users group (just shy of full access)

For a home user there really isn’t any need to have any other permission unless you wanna use the Guest account, probably for the WDTV live, in which case you need to give read access to the Everyone Group (giving it full access is completely unnecessary for the WDTV live, and basically means stripping all security from the file system). Any other entries (like the old CREATOROWNER made by 2000/XP), or entries for a single user etc… aren’t needed at all, only when you need different permissions for each user.

  1. Once you’re happy with the root directory, go to the parent folder of the one/s that are giving you trouble. e.g. if you are having trouble with f:\media\music collections\rock , go to f:\media .

Now open the security tab from that folder and click on “advanced options” =>  “change permissions”. Check if there’s any permission shown as “not inherited” in the “inherited from” column, and delete if you find any. When everything looks just like at the root level, check both checkboxes on the lower part of the window "inherit from parent all permissions… " and “replace all permissions on childs…” and click on apply. That should reset the permissions on all subfolders and files stored under that folder, and hopefully erase any trace of the bogus references to former users that might be hanging there.

Theoretically this could have been done at the root level all at once, however there’s a problem. Folders like the recycle bin or system volume information will be damaged if you wipe their permissions clean from the root drive. Even more so if the partition is the system partition, since it contains a lot of folders like that :  \program files, \windows, \documents and settings etc… So, the best thing to do is fix the permissions at the root level, and then apply step 2) on each folder that you wanna “fix”.

Btw, as for the owner you don’t need to worry that much about it. As long as the permissions are sound, it doesn’t matter if the owner is the administrator group, your current user account or an account stored in a dual boot, the only need to ever take possesion of a folder is to set the permissions in the first place.


#5

Thank you very much,

Your explanation and computerguy’s video on youtube helped me alot in understanding what’s going on at the administrator / owner / guest account level. Took a long time to figure it out but I got it to work in the end.