Yet another Network Share problem (sorry)


#1

So I’ve read all the other Network Share threads and the suggestions they all offered did not help.

As of about a week ago, I can no longer access my Network Shares. I can view Youtube and Pandora just fine. Under “Media Servers” my computer and DirecTV box appear, but if I try to acces my PC (windows vista 64-bit) I get a never ending loading screen until it tells me there is nothing there. Under “Network Shares” there is nothing available. I can access the PC from my laptop and other devices, but not from the WD Live.

Also I should point out, recently when I turned on the device, my computer would make the “device attached” noise which never did that before. My PC would ask for nonexistant drivers. It was around this time it all started happening.

I have tried using TVersity, but for some reason TVersity will not read .mkv files. I don’t know what happened because it wasn’t like it happened directly following a Firmware update.

Speaking of firmware: Version 1.02.21


#2

Hey,

i had just received my WDTV live and it came with version .11 I did my usual update firmware and wham the nonexistent drivers.

I have since said do not ask me and left it and it does not anymore but under device manager the WDTV live shows up with a little yellow question mark. As far as that I have been able to use my pc with it (connected directly to my lan ) and also stream radio and flickr …I am unable to do you tube but think that is because of my stupidity somewhere.

My post on no ip covers my experience thus far and I will be willing to assist if I can in any way.

Let me know what hardware you have router , switch ,computers and how you are trying to connect it.

also antivirus will block it so you may have to make some exceptions

and best to leave the auto connect set as NO

will check back and see what you got

good luck


#3

When you said you read all the other threads and tried all those suggestions did you read specifically the ones dealing with the drivers issue?  Because I think that’s what’s at the core of your problem.  IIRC those people also had failure to connect issues that *might* have had a resolution (I don’t remember because I wasn’t paying very close attention).

Take a look there and see if there isn’t something that helps.


#4

Okay, so after I posted that I did a little more fiddling around and I think I found it.

I right clicked my Videos folder>Properties>Sharing. It was already set up to be shared through the Advanced Sharing button (with which it already had full permissions to everyone), but I clicked the regular “Share” button anyway.

I chose “Change Sharing Permissions”. In this dialog box it had what I assume was a list of devices. There was my computer at the top with “Owner”, and 3 others (2 of which were “”). The only other one, while given a cryptic name, I assumed was the WD Live. I changed the permissions from “Co-Owner” to “Read”.

After that I could see my PC. It worked last night, and works this morning as well. Even though the permissions have seemed to be reset back to “Co-Owner”, it still works…for now.

Next issue to try and fix is the fact that roughly 35 minutes into all my files, the audio starts crackling and falling out of sync.


#5

What kind of files?

MKV containers (with the right audio and video codecs) should play fine.  MP4 will have audio sync issues.


#6

Before, I could play a whole movie no problem. Recently (same time as network issues…maybe it is a firmware issue), I’ll have to restart and fast-forward to correct the problem.

Anyway, VLC says that my codecs for one of my .mkv files was:

Video: AVC

Audio: AC3 (actually A52, but from what I researched, it’s essentially the same as AC3)


#7

Can’t help you much since all my MKV stuff is H264 (which the Live likes just fine).

You might try converting one just to see if it solves your problem.


#8

I have a few newer ones that are h.264. I’ll play them. Thanks!


#9

I believe AVC can mean either H.264 or MPEG-4, both of which should play fine on the Live.  

MediaInfo would be able to specify the actual codec more accurately than VLC (which is often pretty vague).

When using TVersity, it might be a good idea to install the TVersity Codec Pack (optional during installation).  I have no issues streaming MKV files  - make sure to specify no transcoding when creating the TVersity share folders.


#10

AFAIK AVC is a far different beast than H264 (at least a DVD encoded with AVC is – until the recent snapshots, Handbrake didn’t even support AVC encoded blu-rays).

But I’ll be the first to admit I get confused about all this stuff at times (containers versus codecs versus encoding tools).


#11

I looked it up on Wikipedia, so take my statement with a large grain of salt.  My reading comprehension has been known to fail me (read too fast and sometimes skim finer details).  ;)

http://en.wikipedia.org/wiki/H.264/MPEG-4_AVC


#12

Well, Wiki is about a good a source as any other rumor you hear .

As I said, I know that Handbrake up until recently had problems with AVC video (so it was *definitley* not H264) but perhaps there are different flavors of this or that.

I do know that if I use ffmpeg to examine such a file it looks very different than an H264 encoded one, FWIW.