Xbox One and WD Mycloud 2TB

This is driving me mad! So ive installed Xbox media player app and when loading the app it shows my cloud as a connected device but says there’s no files!? Anyone help please!?
On the cloud settings- media: the sharing is on but it says 0 pic, 0 vids, 0 music!?

Any help would be great please.


Cancel that! Found i didnt have media serving ‘ON’ in the shares settings. And now can’t find the delete button for this post

1 Like

Well, now you’ve it basically working, read this to find out how to make it work the way you want it to:

1 Like

cpt_paranoia: Great thread about Twonky!

There are two things missing about dlna and the way it works, maybe useful if content is not available within media players:

dlna streaming is based on so called profiles; during the first connection of a media client with the media server, the client sends a profile to the server: Content of this profile is what the client does support, e. g. file types and codecs.
Other way round: if there is content available for the media server which is not listed in this profile, then this content will not be shown in the client’s UI or cannot be accessible to be played. Problems may occur for example with MKV files. MKV is a container icluding video codec and audi codec(s). Some Smart TV state within their profile, that MKV is supported - but having not the support of the codecs within this MKV. This leads to “video codec not supported” message.

Another notice worth to be take a look is the correct identification. Within the Twonky config pages on port 9000, there is “sharing” and within sharing there is the list of all media clients. Normally, media clients with a good profile cause no problem. But sometimes, client profiles are faulty - like my private older receiver and Blu-Ray player; both are not listed as “xyz DMC” but one as o2juggler and the other as “generic”. After setting them to what they really are by using the massive drop down list, everything works fine.

Both issues described here are related to the dlna client profile, not to the Twonky Media Server. Topic 1 cannot be solved easily as this is bound to the client, Topic 2 can be solved with the help of the correct selection.

Hope this helps :smile:

cpt_paranoia: Great thread about Twonky!
There are two things missing about dlna and the way it works

Thanks. But maybe you missed the third ‘chapter’:

Optimising behaviour for Media Clients

which discusses profiles, media receiver types and how to edit them on the MyCloud…

[edit] but, reading a bit more carefully, you’re right about the need for the profile to be correct, and it sometimes not being correct. Editing profiles is not for the faint-hearted (I’ve only had to dabble in it a little)… I’ll try to edit Chapter 3 to add a succint explanation of the problem of profiles, probably using some of your explanation.

ps. if you think it’s a useful thread, can you encourage someone to pin it, like it used to be, in the forum?

That and a ‘Have you read the User Manual?’ and ‘Have you Read The FAQ?’ would be useful prominently-pinned threads. I’m getting pretty bored of pointing people to the user manual.

Yeah me too. :laughing: Gotten to the point of simply copying an pasting the RTFM text when replying to posts here.

On the subject of incorrect Twonky media device profiles I wonder if that is what causes so many problems with Samsung TV’s. Almost every complaint I’ve seen when it comes to smart TV DLNA problems with the My Cloud is confined to Samsung TV’s. Either that or the DLNA client code on Samsung TV’s is really bad.