WS Mybook essential doesn't turn on

Hi Guys! I have a very old WD Mybook essential (P/N WDBACW0020HBK-01) which worked perfectly for years, i regularly checked his health and it was good. I realized yesterday that it had disappeared from my pc. I checked, and it was turned off. I tried taking the power supply out and putting it back in, but nothing, completely turned off. So I tried on another PC and plugging it directly into the wall outlet, but nothing. At this point I ask, is it possible that there is a problem with the power cord? Because if it was a HD problem it should at least turn on and give me some error. I have bought another power cord which will arrive on Friday, hoping to solve it. If not, is my data lost forever, given the encryption issue?

When plug in you should see LED on or drive should spin up. If none of those then power supply could be dead or the bridge board is dead. Data is still on the hard drive. If new power supply does work. You might want to open up the case and see if you can remove the bridge from the hard drive. Then plug the power supply to the bridge to see if it power on without the hard drive. That should help you which part is dead. Good Luck

1 Like

Thanks! I’ll try as soon i’ll have the new power supply. I really hope it works…