Writing a File to the PR4100

My situation, I have the My Cloud PR4100 connected to a LAN using a static IP. On the same LAN i have a Matrox Monarch HDX and a D-Link DNS321( NAS) connected to the same LAN. The Matrox fit is a video streaming unit that is attached to a video camera. The Matrox unit currently can write a video file to the D-LINK unit successfully. I want to replace the D-LInk with the PR4100. I specify the following address of the PR4100 on the matrox unit //192/.168.1.100/Public/Videos/ . This appears to be accepted by the matrox unit as an acceptable address. But when I try to have the matrox unit write a file to the PR4100, it fails. Also specify a user ID and password on the matrox unit for use with the above address. I tried to specify no users ID or password on the matrox so that it acts as a guest on the PR4100, but this fails as well. I have not trouble mounting the PR4100 on my MAC or saving or reading a file on my MAC from the PR4100. I am not sure what I am doing wrong. There must be something in the setup on the PR4100 that is not correct. Any suggestions would be appreciated. Thanks

That’s not a valid ip address. Try //192.168.1.100/… and maybe it needs backslashes instead? \

My apology I did not type it correctly when I typed my note. I specified //192.168.1.100/Public/videos/. The Matrox unit will not accept “\” as a valid character for a pathname.

I have been working on this for the past 4-5 months and I cannot get it to work. I am suspecting it must be protocol related issue. The Monarch HDX validates the IP address but I am not sure how it does this. If I type an incorrect pathname it will reject it. For now I have removed all permission levels. From a MACBook connected to the same LAN, I can read or write a file to the PR4100 device. With my setup I have the Monarch HDX, the D-LINK and PR4100 connected to the network all with their own assigned static IP address as assigned by the router based on their MAC address. From the MACBook I access the Monarch remotely through its console to start or stop the recording and to change the pathname on the Monarch HDX. I see if a view file has been created on the D-Link or the Pr4100 NAS units. In every case I can get a video file created on the D-Link but not on the PR4100. So I do not know what is wrong. I should be ale to have the Monarch HDX write a file to the PR4100 as it does with teh D-Link. The support at Western Digital claims the issue is with the Monarch, as they are unfamiliar with the Monarch. The PR4100 user manual covers all aspects of mounting volume from he PR4100 to either Windows or MAC. I am open to any suggestions as I am at my wits end on this. Dave

I don’t know that matrox unit, nor your MAC sharing setup, but I suspect it uses SAMBA, the windows sharing protocol. You could try to fiddle with the samba version in the WD UI settings.
As I don’t have more details, I can’t help you further.

I have not setup the SMB option on the PR4100 and thus I have not tried this. Not sure of what to specify for this setting. I noticed there is SMB1, SMB2, SMB3, not sure what to specify for the SMB protocol?

I have tried SMB1,SMB2 and SMB3 setting on the PR4100 unit and no luck. I have no permission level setting on the PR4100 in order to keep things simple. I can mount the PR4100 on my MAC desktop, write and copy a file with the PR4100.
The only setting I have on the Matrox Monarch HDX unit is the pathname, Workgroup and user ID and Password setting. I have tried to sett the workgroup to WORKGROUP the same setting on the PR4100 with no luck. I am getting to the point that the PR4100 is not compatible with the file transfer mechanism of the Matrox Monarch HDX streaming device. Yet it works perfectly with the D-Link DNS-321 with and without the user ID and password settings. The path name I use on the Monarch HDX to work with the D-Link unit is //192.168.1.105/Volume_1/Video/ and to use with the PR4100 I specify //192.168.1.100/Public/Videos/ . There is something not right with the WD PR4100 unit that it cannot accept a file writing mechanism from the Monarch HDX. The Monarch HDX unit is a dual function unit where I can send a separate video streaming to a remote Apple TV unit that decodes the signal using the VLC app. This works perfectly. The Monarch HDX can also save the same video stream to a file. Both functions operating independently with each other. My thought of replacing the D-Link unit with the PR4100 because of higher storage capacity, it has a dual Ethernet and power supply capability. Also to take advance of it cloud functionality. But I ahem been trying to get the file writing function to work with the PR4100 for the past 4-5 months without success. I am really surprise with this issue given the popularity of the WD PR4100 unit as a network storage unit. I expected it to work the same as the D-Link but with more bells and whistles. Thus I am hoping someone can help. I believe the fault lies with the DW product. Thank you Dave

The D-Link box claims only FTP and upnp (dlna) support… I guess samba was included too.

The matrox box has samba and nfs support.
http://www.matrox.com/video/en/products/monarch_hdx/specs/

SMB
Try to set smb2 and reboot the PR4100 and just try to write to the Public share, not a subdirectory.
Find a windows PC and try writing to the public share, try the same with a macbook.
If all that works, it should work for the matrox too.

NFS
Go to settings - network - enable NFS
Go to shares - Public (or another share) and enable NFS on the share
The mount point will be shown…
Try writing to SOMEIPADDR:/nfs/Public

Good luck