Write-caching will not stay enabled in Windows 7 x64

Dear Forum Users,

My OS drive is a WD Cavier Blue 500GB Drive (“WDC WD5000AAKS-22V1A0”). My OS itself is Windows 7 x64 (Build 7600).

I read on some sources that turning on Write-caching on a drive can increase performance. I checked my drive settings, and indeed write-caching was not enabled:

WD_writecaching.jpg

I then proceeded to turn it on, without any apparent problems. However once I restarted my PC the option was turned off again. This keeps happening repeatedly. I cannot seem to turn it on and make it stick.

I’d like to note that I also have another internal drive WD Caviar Green 1TB, and it has the option turned on without any problems (however it’s not the OS drive like this one is).

Any ideas why this is so? Is this a problem with my WD Cavier Blue drive or with Windows 7??

I looked everywhere online but found no solutions.

Please Help!!

Anyone?

No one at all?

Hello?

WD Staff, can I get a reply please?

Thank you!

C’mon guys…

??? =\

Hopefully I can help you out with this. Somethime this setting is not really hard drive related. Please make sure you have the latest SATA storage drive in your system, for example Intel Rapid Storage Technology.

Then you make this setting in this tool and it will be in there even after reboot!

Just give it a try :stuck_out_tongue: