Would like to try rolling back firmware on WD Live Plus Where to find versions prior to current?

There’s a WD Support page about this topic here:


Thanks Grant, new to this board.   Would really have liked 1.04.17_B but doesn’t seem to be offered.  Everything worked great on this one for me.  With the .18_B upgrade, just added yesterday, I have lost the ability to read .jpg files from my iPhoto library using Medialink on OS X as well as from a local drive.

Have you tried a 3-Stage reset with 1.04.18_B?

  1. Reset to Factory Defaults within Settings > System.  Allow system to reboot.
  2. Press side Reset button (paperclip is your friend).  Allow system to reboot.
  3. Power cycle.  Pull out the power plug and leave it unplugged for 10 minutes.

Plug power back in and see if you still have issues with your JPGs.

Some users have accomplished similar “fixes” by rolling back and then re-upgrading.

WD pulled the 1.04.17_B firmware because some users got stuck in a firmware reboot cycle when updating via USB. Someone may have a link to it but I suspect it’s no longer on WD’s server.  If you do find it, bear in mind that there is a risk of the update getting stuck in a loop.

Tried the 3-step reset and no change.    Wonder if there is a problem rolling back to 1.04.10 and then possible re-upgrading?

Otherwise I’ll just not use my photo’s and wait for another upgrade to the firmware.  Getting a little frustrating…wish I hadn’t upgraded in the first place…all was working well.