World Book II problem

I have a 2tb raided worldbook that has stopped.

It has one white light on, just the bottom one.

I have tried holding the reset button, doing the 30-30-30 reset, I can’t get to the dashboard either.

I have no light activity on the network adapter either.  Only a solid green light.  No blinking orange at all.  Yes I have tried other cables.

2 questions, is there anything else I can try?  and/or how can I access one or both of the drives to get the info off it?


Hi jeffkics, since you are trying to recover your files, I recommend you to contact support first before trying anything else.

I have contacted support, they said its out of warrenty. nothing they could do.

I don’t have the World Book but have the Shared Storage rather. But from looking at the pics of the interface (web GUI), it is near identical.

Here is what I managed to come up with as far as LED codes.

Which by the way is the same manual for the original World Book.

One thing I am certain of is the if the unit is not booting up completely, you cannot reset or power off the unit.

At least this was the case with mine. I had to manually pull the power plug from it to shut it down. 

One would think that if the drive is not booting it would throw the “Boot unsuccessful” LED.

But since I am unfamiliar with the exact unit, let’s not go to the point as it not being booted as being the problem yet.

Please explain the type of network this is hooked to. For instance router/switch model? 

I presume this is hooked up straight to a router since this is the normal setup for an end user. 

The solid green light you talk about is where? On the back of the unit where the ethernet cable plugs in?

With the ethernet unplugged, do you see that light then (most likely not).

So basically when you plug in the ethernet, the light turns green, but you get no actvity (orange) at all?


Just to test the actual functionality of the unit, let’s try just a normal shutdown.

Hold the power button in for at least 4 seconds and see if it shut’s itself down. 

Just to clearify, this is a My Book World Edition II

The only light that comes on is the bottom white light.  During the first 30sec from powering on the top light blinks once and that is all.

It is connected to my router.  I have also tried connecting it directly to my computer.  Yes the green light goes off when you unplut the cat5.  Under normal conditions, you get a green light when you plug it in, and then an orange activity light comes on and blinks this no longer happens.

Nothing happens as far as powering it down using the power button, or the reset button.  Nothing happens.

At this point I just need to get the info off the drives.

It sounds to me like it is not even booting up. 

I’d like to confirm this by you installing this

Once installed, it will auto search for it.

BTW, you can’t connect it directly to your computer via cat5 unless the cat5 is a crossover cable.

Even then you would have to deal with DHCP being assigned or static ips.

Not being able to power it down gives me the inclination that it is not booting up. Mine will not power down

and the reset is non functional when it is not booting up completely.

If it is connected to your router, you should be able to look at “attached devices” and see if it is dhcp an ip address for it.

How was you connecting to it previously?

If after all this… We confirm it is not booting up, then we will move onto removing the drive and putting it in as a slave to retrieve the data. I have to look at the type or drive(s) and the raid setup, if any.

Also could you post a picture of the front of it. This way I can see the width and stuff. Some are 2TB (1Tbx2) while others are different. 

The board will probably look like this

The router is not seeing or giving a dhcp address to the unit.  There is no activity on the network adapter “no orange activity light”

It has 2tb x 2tb  Raid1 2tb

Sorry for the late reseponse, the week has been quite busy.

I am going to treat this as a dead soldier. Raid 1 is good since it just mirrors one drive to another. Remember, I have the WDShareSpace and not the World Book. But until someone else comes along more familiar with it, I will do what I can. I can’t imagine them being all that different. I believe the ShareSpace is a better version of the World Book, but don’t quote me on that.

How valuable is the data on it?

When working normally, the light is lit up from bottom to top? Always starting from the bottom?

Do you have access to a Western Digital 2TB or less Sata hard drive that can be wiped and reformatted? This only applies if the data on it is valuable and needs to be retrieved. Of course retrieving the data will require enough space to do so.

Method of attack:

Plan A:

Use spare drive that can be wiped and formatted. Any size from 30GB to 2TB. I am thinking it must be Western Digital since the ShareSpace will only use WD.

Delete all partitons from that drive.

Put that drive back in and boot it up. It should repartition the drive. 

Plan B:

Backup data if needed.

Delete all partitons from one of the 2 2TB drives. 

Put that drive back in and boot it up. It should repartition the drive.