World Book - Blue rings

Hey WD Community

I have had a World Book for a few years and its been working great. A couple of weeks ago I was transfering a file to the drive and started to watch a movie stored on the drive. The transfer had been running for some time before i started to watch the movie.

While watching the movie it froze. I rebooted the WD live TV device that i was watching the movie through and it wouldnt access the drive. I then power down the WD world book and then turn it back on. The drive started fine. I then started to watch the movie again with no problems. After the movie I tried transfer the origanal file to the drive. All looked to be going fine. I return to check progress some time later and go the error message that the network drive was not accessable. I turned the drive off and back on and then tried to transfer again, resulting in the same message. This has now gotten worse to the point that I have to power down several time before I can access the drive.

Looking forward to your comments


I think the unit is just failing and is not related to the file transfer

1 Like

The same thing happened to me, but just with accessing the drive from my home network. I had to reboot the drive each time I wanted to use the MyBookWorld. This happened for about 2 weeks, then it completely stopped responding. I suggest you back up your data soon. My router recognizes the drive and shows it in the device list, but cannot see the drive using My Network Places in Microsoft XP. The individual drives seem to be functioning (I took them out and connected them to a Linux box, but I’m wondering if the Linux driven hardware in the housing is malfunctioning. Does anyone know if the WD2000D033 uses the same housing as the WD1000D033? I want to swap the drives into the other NAS housing and see if I can access them.