WORKING FIX Time Machine + Lion

Finally got Time Machine working with Lion!  (All credit goes to yagi for this one)  Go here and follow the directions: http://mybookworld.wikidot.com/forum/t-379023/netatalk-2-2-on-mybook-whitelight

This will update netatalk to the latest version (2.2 final) and get time machine working!!  I followed the directions exactly and am backing up as we speak!

If you need any help, just post in this thread :slight_smile:

1 Like

its funny that a private finished the update before WD shame at you wd

Well. Beeing a software engineer myself, i know that its a difference to get a software working and to get it tested and ready for offical use by customers.

I don’t know how many people are working at wd on the mybook software (i guess only a few). My bugfix is working, but its neither perfetly integrated nor fully tested. I use optware, but for an official release you have to update all libraries and check if all other programs are still working.

I for myself only use ssh and afp … 

Wow over 1100 views and no one’s commented to say if they got this method working?

I’d like to give it a go as I really need to access my old back-ups.

Just look’s very confusing!

Would be happy to help out!  Do you know how to SSH to your mybook?

Roughly - never done it though.

Do you have MSN or anything? Would be great to get this working.

Can you email me at SNicholls27 @ gmail.com if possible?

Regards

Ok, I just invited you to a chat in gmail

I have having the same problem and would very much appreciate any help you can offer. I am a basic computer user, so I find the link to the fix very difficult to follow.

Sure, just so I know do you have any experience using the terminal?

Are you interested in an automatic installation process of netatalk2.2? I could write a small script, that install optware, the latest netatalk and update your config files.

If more then 5 people are interested i’ll write a small shellscript and put it online. 

1 Like

Ah well… i wrote a script to install it… go there:

http://mybookworld.wikidot.com/netatalk2-2-on-whitelight 

3 Likes

Yagi,
Your script works perfectly! Time Machine with Lion is back. Thank you for your outstanding efforts!
Rex

That looks great - I’m still a bit reluctant to go with a ‘hack’ if an updated firmware is imminent…

So before I go ahead… how safe is this?  What will happen when the firmware is updated?  Will it overwrite this change?  Is there any risk of loss of data?

Hi Crosbie,

i think my install script is quite save. I tried it now a few times with my own mybook and didnt have any problems. When there is an official firmware upgrade, i think it will override all changes made by my script and you will have wd’s netatalk version.

Also its almost impossible that you loose data.

Give it a try, i doubt you’ll regret it.

Cheers

2 Likes

Okay, tried this, but got lots of errors.

------code-----

Do you want the new afpd to start on system startup? yes/no?

Installing netatalk (2.2.0-1) to root…

ipkg: extract_archive: /opt/etc/netatalk/: File exists

ipkg: /opt/etc/netatalk/AppleVolumes.system: Not a directory

ipkg: extract_archive: /opt/etc/netatalk/uams/: Not a directory

ipkg: /opt/etc/netatalk/uams/uams_guest.so: Not a directory

ipkg: Cannot create symlink from ./opt/etc/netatalk/uams/uams_dhx2.so to ‘uams_dhx2_passwd.so’: Not a directory

ipkg: Cannot create symlink from ./opt/etc/netatalk/uams/uams_clrtxt.so to ‘uams_passwd.so’: Not a directory

ipkg: /opt/etc/netatalk/uams/uams_dhx2_passwd.so: Not a directory

ipkg: /opt/etc/netatalk/uams/uams_passwd.so: Not a directory

ipkg: /opt/etc/netatalk/afpd.conf: Not a directory

ipkg: /opt/etc/netatalk/netatalk.conf: Not a directory

ipkg: /opt/etc/netatalk/AppleVolumes.default: Not a directory

Configuring netatalk

Successfully terminated.

Now we modify the config files.

rm: unable to stat `/opt/etc/netatalk/AppleVolumes.default’: Not a directory

ln: /opt/etc/netatalk/AppleVolumes.default: Not a directory

cp: unable to stat `/opt/etc/netatalk/’: Not a directory

cp: unable to stat `/opt/etc/netatalk/’: Not a directory

sed: /opt/etc/netatalk/afpd.conf: Not a directory

-------end code------

Trouble with ipkg?  What’s up here?

The upshot is no afp support at all, unless I manually run afpd.bck from the terminal.  Wah!  Can I undo this, or can you see a fix?

I sent you a private message. Please reply to it, so i can help you.

1 Like

Have done - thanks.

it seems there was a problem with the user rights and ipkg wasnt able to install netatalk anymore.

we solved the problem by deleting the folder /opt/etc/netatalk and started the script again.

2 Likes

yagi_, thank you very much for the script! Excellent job! Backup is working without any issues :slight_smile: