Workgroup credentials for "smartware" log in? my cloud, nope, should be called my nightmare

It seems mycloud has decided to throw yet anohter curve ball my.  Now, for some unknown reason, it is requesting login credentials.  I have tried every username password combination I can think of but none work.

I saw a similar post but I get this error when skimply trying to get smartware to run.

Also, mycloud does not show up on the network in windows explorer (windows 7 pro 64)

Anyone know how to “fix” this?    

Providing an image of the login request would help, is it asking for a network password or a My Cloud password?

What error do you get when you try to use SmartWare? Again a image or the exact error info would help?

I suggest unplugging your router at the router for one minute and then plug it back in. Give everything time to reset then see if it shows in your network.

Posted by,
cat0w (USA)

I am having the same problem.  See screen dump below


I found a great explanation of what login credentials it is actually asking for.  I have tried many but I did not specfiy the domain.  See the link below.  I used the backslash () nomenclature to specify the PC and username and this was accepted.

Most relevant info: 

you can specify “HomePC\PikkHome”, or “PikkHome@HomePC” as the user name to specify both the user name and the domain in one field.