Won't play AVI files after update

So I turned on my WDTV today and it greeted me with an available update. I pressed ok and it updated my system to 1.06.43_v

Everything seemed to go ok except that now it won’t pay AVI files over my network share any more. I can fast forward and rewind the file but pressing play seems to perpetually pause it. MP4 and MKV files seem to play fine. 

I have only ever played files over my network share and the new update seems to have broken something. I tried resetting to factory defaults without any luck. 

Any help would be appreciated.

1 Like

Updated mine yesterday and have exactly the same problem.

Have tried resetting to factory defaults and cycling power at the mains as suggested for other issues but still can’t play some avi files, as for mac0z the files just pause when you click play but you can ff and rew ok.

Anyone else seen this or has a solution please?

Many thanks.

It turns out that the AVI files will play. They just take about 1 min to load. I thought it was malfunctioning after waiting about 20s.

In any event, hopefully the next update will fix this.