Won't eject USB


#1

After a few days of normal use with a brand new WD Elements 1.5 TB, WD Live hangs on eject function.

Have to manually power off , which already caused some data loss and corruption on WD Elements.


#2

Is it chicken or egg? Is the the WDTV hanging because there has been some corruption on the hard disc or did it cause it? As far as I am concerned if you power off the WDTV and remove the plug then you can remove the hard disc without using the eject button, just like you can on a computer. The eject is designed to disconnect the disc in a controlled way so that you can remove it with WDTV powered up. Its the equivalent of ‘safely remove hardware’ on the computer. 


#3

It did cause the problems.

The WD HD is just out of box, being used for a week.

The files transfered to HD are fine on PC and other media player I own.

Using WD Elements 1.5 tb with WD TV live caused corruption ( 14 files) and loss (23 files) of the data.

I see people posted this problem’s descibtion on this forum before me , sorry for doubling the info.

“As far as I am concerned if you power off the WDTV and remove the plug then you can remove the hard disc without using the eject button, just like you can on a computer.”

It would be great, but  the power off button in the described scenario doesn’t work either!

Had to disconnect the wall-wart manually.

Right now I can not find a use for WD player. At all.

Streaming media from servers and watching Youtube - that I have had before.

My idea was to plug 2 big HD USB drives to WD TV live , eliminate the PC and have all my files ready whenever I need them with a normal playback functionality , that one gets out of a $ 20 mp3 player.

Not to run Chkdsk /f on 3 Tb of HD every week and manually change folders.

Unpleased by WD by now.