Won't backup Probably encountered a thousand times

I just bought a mycloud 2TB. I know it’s something simple and I think it’s the uname pword. I have downloaded smartware and choose my computer and then mycloud. It asks for a uname and pword…I’ve tried them all. I think that’s why I can’t get past this screen. I’m frustrated and don’t have a lot of extra time to geek out with my limited abilities…what the heck uname pword does it want? I just want to be able to backup (mirror) my hard drive files. Please help and be kind if there is a faq explaining this. I’ve heard such great things about the mycloud and I’ve just felt frustrated since I bought it.


BTW, it is connecting through my router, it is a direct connection and I can see the drive. No problems there. I’m just not doing something simple and I know it :frowning:

Are you able to provide a screen shot of what comes up asking you to enter a user name and password?

Is it asking for a network UN and PW or a My Cloud UN and PW?


i woke this morning and tried again and it is backing up right now. I would hit the start button and nothing would happen, no screen shot would help. I don’t know why it did it this time. I had the same problem with the upgrade offered for three computers for free. I would hit the button and nothing, this morning it upgraded. I did nothing different. I’ll try on my other pc’s later today. I am using google chrome and from looking around the website, mycloud prefers firefox, that may have been part of the problem. If I have issues with my other pc’s I’ll post to this thread again. Thank you so much for trying to help, I really had done my research before I posted but couldn’t figure out what I was doing wrong. Who cares, it’s working now! Thanks!!!

If you don’t have it here is a link to the SmartWare User Manual.

This can also be found at the bottom of the SmartWare Help tab, Online User Manuals.