Wireless USB worked with FW 3.49_B, but doesn't with 4.10_B

Media Player: WDTV Plus Model  WDBABX0000NBK

USB Adapter: WL700RN USB 802.11n Wireless USB Adapter

Current Firmware: 1.04.10_B

The wireless adapter listed above was working flawlessly with FW 3.49_B, but after I upgraded my FW to 4.10_B, it stopped working and doesn’t detect the device.  Shouldn’t firmware enable new features and add additional support, not disable it?  Any information that would help to get this working again would be greatly appreciated.

Please don’t tell me to buy a new adapter that’s listed as compatible.  That’s not a solution, that’s misdirection.  I just purchased the W700RN online.

Rollback the firmware to the one that worked. Follow the instructions on the link below.


Come on WD - this has been broken for weeks. i bought your product, I bought the N based wireless you required and the first update broke it. Even after rolling it back N doesn’t work. How long do you expect us to wait for you to make your recommended USB deivces to work with your device?

The wifi adapter now works with the latest firmware update.  Good job WD!