Wireless Question

I am wondering if there is a way to have my wireless connection automatically connect when I power on the WD TV Live?  What I have to do now is go into network setup and I select preferences and it detects my wireless network.  I then am able to go into my wireless favorites and select my network and then it will connect.  I have to do this every time I power it on.  So, I am trying to find a way that it will automatically connect for me.

My equipment I am using are:

     Wireless router - Linksys WRT54G2 v1

     Wireless USB Adapter - DLink DWA-160 (H/W Version: A2, F/W Version: 1.40)

Any help would be greatly appreciated.


Well it should always connect when you power up. You could try resetting your WDTV by pressing the side button with a paperclip / cocktail stick with the unit on and fully booted up. Press it for 1 second and then release - the unit will reboot.

The only other reason could be that the adaptor is not in the approved list.

D-Link Xtreme N dual band USB adapter DWA-160 Not Listed*

Note the revsion / version is not listed whereas you have H/W Version: A2, F/W Version: 1.40. This update could make all the difference.


The only other thing to ask is if you are using the latest firmware. It appears that it may have made some adaptors not work correctly even though they worked before the firmware update. If you have the latest firmware you could rollback and see if that cures your problem.


I am using the latest firmware version.  I had upgrade from whatever the default one is.

I have downgraded the firmware using the wdtvlive_1_3_49_V_Rollback file.  However, it has not fixed my issue of the wireless not connecting.  When powering up, if I check in the Network settings, it shows my wireless network in the info listed, however, it is not connected.  I have to go through the steps of manually connecting to my wireless network.  This is a real pain having to do this all the time.  When I do get connected wirelessly, it works flawlessly, just wanting to get it to auto connect.

OK try the firmware you were using before. 1.04.10


Plus don’t forget to reset the WDTV by pressing the side button using a paperclip / cocktail stick. Press for 1 second with the unit on and fully booted up. It should reboot. You could try that before you upgrade and definitely after.

When reseting and upgrading the unit, should I have the wireless dongle inserted or taken out?  I have read on other posts that you should unplug the wireless before upgrading.

I followed your advice, however it still is looking like the wireless dongle is powering down when the wd tv is powering up.  It blinks a couple times and then stops until I go and manually connect and then works flawlessly.  I’m getting to the point where I may have to drill a hole in my floor so I can directly hook the wd to my router rather than going wireless.

Is it possible that the reason my wireless doesn’t automatically connect have anything to do with the fact my wireless rounter is not on the apporved list?