Wireless Pro now unmountable on MAC and extremely slow on PC

Hi WD Community,

I’m desperately reaching out for some help regarding my issue.

I’ve bought the 1TB drive back in July 2018 to be able to transfer footage on the go of a lengthy project of mine that I’m trying to document as much as possible (a house construction build by myself).

Last month (mid Oct. 2018) I noticed that its storage was getting full (960GB out of 1TB) and it had drastically slowed down the drive execution speed. I then decided to back it all up on a Seagate 6TB. But during the operation the WD drive froze for several hours (only transferred about 34BG, corresponding to the space left on that drive) and I had to unsafely eject that drive since it wasn’t responding for hours.

Here are some specs:

  • I used a 2017 MacBook pro running Mac OS10.13.6 to do the backup
  • WD drive stay as default format in FAT32 (exFat) since I didn’t know if it had to stay as is to run the SD card imports or if it would also work under Mac OS Extended (Journaled) format.

Today’s situation:

Fast blinking lights on the drive after about 60sec every time I try to connect it.

The drive won’t mount anymore on Mac operated computers, I tried on my 2017 MacBook Pro and on a 2012 iMac. In Disk Utility it appears (after at 5-8 minutes) as connected volume but all greyed out and showing not a single 1KB available on the drive. No repair possible and only option offered is to format the disk which I’d like to avoid so I can retrieve the files first.

On NTFS for Mac , it shows as well (somehow quicker than on DU, 3min to show up) and same as Disk Utility, all greyed out, no space available on the volume and not option available 8because greyed out).

Looking into it on the web, I attempted to restore (reset) the drive accordingly to this topic:


As well as :

With no luck.

I attempted to eject the drive via Terminal commands that might help resolving some errors left on the drive after this unsafe eject.

I also tried to access the files via apps such “Mac Data recovery”, “Stellar Data Recovery”, iboysoftdatarecovery"… and so on.

Found a thread that recommended to plug the drive on PC since Fat 32 (ExFat) is PC native. For some reasons the drive seems to be unresponsive on PC for about 10min, then it mounts, files are there but any operation is very slow (opening folder or file), it would take several minutes and if I attempt to copy paste any file from the drive (even the lightest of all) it ends up timing out and not pasting anything.

I reached out to a Data Recovery Lab who quoted me about 1250€ for this operation since “it would require a white room data recovery”. Which I very doubt so for now.

The disk itself, when plugged, spins properly and not clicking sound of the needle is heard, it just sounds like it performs correctly.

Would any of you, out here, know of the issue I’m facing and some eventual fix to solve it?

I would very much appreciate your help.

Sorry for the lengthy post but I felt it was relevant to detail chronologically all the steps.

Best

Hi sylvainlacrx,

Unfortunately, it seems that drive has gone bad which doesn’t allow to read data from the drive. It is best to contact Data Recovery to recover important data from the drive and contact WD’s Technical Support to replace drive if available under warranty period.

Hi asp73,

Thank you for your answer.

To be honest, I was deeply hoping that I won’t have to go this way.

Thanks anyway.