Wireless Pro, no NAS, auto connect and can it be direct charged?

I have 3 questions about My Passport Wireless Pro 3TB:

  1. Is there a way to have it auto connect to an SSID upon boot? Its very inconvenient to always have to connect to it first and set it to connect to my wifi ssid.

  2. I have updated my WIndows 10 Pro with every SAMBA feature in the Windows additional features menu (aka Turn Windows Features On or Off). I cannot connect to the drive as a NAS from Windows 10. That is 3 different Windows 10 machines and 2 virtual machines. Connects fine from multiple machines running Linux or BSD. Any tips?

  3. Is it possible to direct charge this (not via computer but plugged directly into the wall) if it is on and I have “Drive lock” off? My goal here is if I can have this run as Plex server plugged into power without having to activate “Drive lock” all the time?

Thanks!

  1. You can change the Wi-Fi setting to only connect to a SSID (uplink) and not broadcast its own (downlink). Every boot up will reconnect to that SSID (i.e your home Wi-Fi). You can find this info in the user manual available at support.wdc.com.
  2. Are you able to access it by typing in it’s IP such as \192.168.60.1? If not please contact the WD Support team directly for help
  3. Drive lock has no effect on the charging. The MPWP will not charge when the HDD is spinning and when the device temp is too high. You can leave it on to the wall operate and charge when the HDD goes into idle mode automatically.

Thank you!

  1. Looks like what I need, i will give it a try!

  2. I mean I can access it’s admin website in a web browser. I am speaking of accessing it like a network attached storage device. So if you mean accessing it in Windows explorer via \\192.168.60.1? Then no this is not working. However I can mount it as a NAS in Linux and BSD.

Its the same problem as this guy: My Passport Wireless Pro Windows 10 File Explorer problems. Besides Linux and BSD, I have spun up a WIndows 7 VM and I can access the Passport Wireless pro as a NAS in that.This seems to be a Windows 10 problem. As I noted, I tried everything in that thread but its still not working and I was wondering if there are other threads on it I did not find with more troubleshooting steps?

Quick question on this, I assume the username and password for the NAS share is the same as I set for the admin webui. This is what worked on the other platforms. Might there be a special authentication issue on Windows 10?

  1. Does this mean that if I am streaming from it to a Plex client, I cannot simultaneously charge it from a wall outlet?

Thanks again!

The earlier MPW could be connected to it’s PS and although it did not charge, the battery reserve did not go down, but the problem with 24/7 connection to power eventually wore down the battery and many began to fail.

If you want to use it as a NAS, then get a NAS; the wireless drives are made for occasional use, and not meant to replace a “real” wired NAS.

No idea why you chose to infer things I did not say in a HELP thread.

  1. It is advertised as being able to be network addressable. This function is broken on Windows 10 for me and I am asking for HELP.

  2. I do not need this to be what you are projecting on me. I bought this for an upcoming work trip where I want to use it as a Plex server in the condo work rented for me for a couple weeks. I am testing it now to see if it will work as I need it to or if I will be returning it.

  3. I have a large home SAN and experience with storage networks, so I think I have more experience than you in what I need, which is why I did not ask for any advice there. My issues are specific to the way this unit operates and I do not have time to spend days tinkering with it (though I would love to do so if I did), so I came here to fast track my troubleshooting.

  4. If you have nothing helpful to say, please move on. If you can help me, than I would really appreciate it as I am running out of time and I am starting to lean towards returning it. The Windows 10 specific issue is most troubling as I will only have access to WIndows 10 machines on this trip.

Sheesh, chill out.

I have a MPW gen1 as well as other wireless drives. I can address the dasboard from a Win 10 or Win 7, and play media files from it when the MPW is on the home network; but playing media on a laptop is so “yesterday”. I travel with mine often and have an iPad with which to view movies from it’s wireless signal Can do same using iPhone+, too.

Over time the battery in the unit CAN get ruined if is mistreated by keeping it plugged into power for weeks and weeks.

I find the MyCloud app does a great job for viewing mp4 movies on a mobile device. I have Plex on my WD NAS home server, and I find it to be a bloated program that I find unnecessary. I only use it (via Plex mobile app) infrequently to view movies and listen to music on a mobile device. I can even do this remotely using the Safari browser.

I apologize if any of my help was unappreciated. Get over it.

Once you set up a coonection to a network (ssid) it will automatically reconnect if the network is available.
I have no issues connecting with my win7 ultra setup. Mine is a 2TB unit but otherwise identical. I generally use my iPad.
I often leave my unit plugged in when streaming. I figure the built in charger should be smart enough not to overcook the battery. From memory there was nothing in the user manual suggesting that leaving it plugged in via charger would cause damage. The older model may have been different in that regard.
Seems like the connection issue is a win10 samba issue? May get more assistance from ms forums re that issue.
Have you tried UPnP connection from win10?
Re streaming, I found the built in Twonky server to be superior to the Plex server. Takes only seconds to rebuild the library where Plex ties up the drive for ages.

When accessing files either the WPW Gen 1 or the newer WPW Pro from my network, you have to use the IP address that is assigned by the router to access files on these devices.

i.e. if you do 192.168.60.1 you will get the admin login screen.
i.e. If your router assigns 192.168.0.100 (for example), and you type 192.168.0.100 into the address bar, you will get access to the files.

I have no trouble booting up the drives and getting them to connect to the network on restart. If I switch networks (i.e. move the drive to another building with a different network), then I seem to more often than not wind up having to re-establish the connection to the host network by accessing the drives admin console.

Once the drive is on a host network, it will show up as a network drive from the explorer navigation pane, just like NAS drives show up. That is normally how I access the drive.

In the advanced options, you could direct the unit to use a static IP address, to make this a bit easier and more reliable. I do that with my NAS boxes and these wireless units. With a static IP address, you could map a drive letter to these devices… . .but for security (ransom-ware) reasons, I do not use drive letter assignments for remote drives.

So, in many respects the unit will act like a NAS drive when it sits wirelessly on a network. But as others have stated, this is by no means a NAS drive. For starters, it is connects wirelessly to the network which usually translates to slower, less reliable, transfers. Second, my NAS units have WD red drives, which are made for 24/7 NAS use. I doubt the WDW units have this caliber of drives in them.

Re leaving wireless pro unit plugged and powered on full time. The online support section states that when left permanently on charge the wireless pro will actually discharge to 85% capacity and hold there. I assume this is to prevent overcharging damaging battery. Powering off and back on will allow the unit to reach 100% charge again.

Yep, but why push one’s luck with this action?

True. Not worth the risk.

Overcharging and over-discharging are really damaging to lithium batteries of any type. WD seem to have taken steps to reduce the risk of overcharging by allowing them to slowly discharge while still connected to power, That’s quite clever.

I’m not sure what sort of discharge protection they have built in to these Pro units.
Do they shut down nicely or just die as the battery goes flat? That can be just as damaging to their longevity as overcharging.