Wireless password no longer accepted after shutting down the unit from Dashboard (firmware v1.03.04)

Hi there,

I came across a serious problem with the current firmware of the WD My Passport Wireless Pro (v1.03.04).

After updating to this firmware version I selected “Shut Down” in the Dashboard. When powering the unit up again, it no longer accepted my wireless password, neither for the 2.4 GHz SSID nor the 5 GHz SSID. I definitely know I did not change this password after having defined it. I am the only person using the drive (and I am the only one knowing the password). The password worked very well all the time before, for both SSIDs. After shutting the unit down from the Dashboard and powering it up again, the password no longer worked. Trying the original wireless password from the sticker on the drive (last 8 characters of the serial number) did not work either, neither for the 2.4 GHz SSID nor for the 5 GHz SSID. I did define an admin password in the Dashboard though, and I also know this password, but the admin password should be an entirely different story. Wirelessly connecting to the unit is no longer possible without first resetting the wireless password manually.

More information: I purposely never connected the drive to my WiFi (internet). I am sitting with my notebook only 5 feet away from the drive. Battery status is more than 80 % both on the drive and on my notebook. The wireless LED is lit, the function LED is blinking very slowly. Maybe an additional information: After purchasing the drive I first tried to manually update the firmware to version 1.03.04 via 5 GHz wireless connection. The update process started but even after 60 minutes was not finished. I turned the drive off, manually reset it to factory settings, copied firmware v1.03.04 to an SD card, inserted this card and powered it up again. The manual firmware update to v1.03.04 worked flawlessly then. Only the drive capacity was no longer shown as 3 TB but as 2.7 TB afterwards (?!). Before it was 3 TB, I am pretty sure. Sample videos, photos, sound files were all still present. No other data has been stored by me. I could use the Dashboard as expected. Only after shutting down from the Dashboard the password was gone.

Has anybody else encountered this? Should a “Shut Down” from the Dashboard be avoided?

Thanks a lot
Alex

We have discovered an issue when unsupported characters are being used in the password. Specifically an ampersand “&” character. It will allow you to setup the WiFi connection initially, but after a reboot, the password no longer authenticates. I have provided links below for more information on using special characters.

Hi Timothy,

Both my wireless password and my admin password consist of English letters and some digits only, not a single special character was used. I exactly followed the WiFi host password rules: WiFi host password contains alphanumeric characters only (a-z, A-Z, and 0-9). The password length is between 8 and 63 characters. Special characters (*, &, %, ect. ) have not been used.

Could you, please, also read through my additional information in my original posting? Has there been an undocumented change regarding the disk space notation in one of the recent firmware updates for the WD My Passport Wireless Pro? When I used my 3TB drive for the very first time, there were “3 TB Free” shown in the Dashboard (original firmware, can’t remember which version number). I never loaded any media files to the drive. I only started a manual firmware update to v1.03.04 from the Dashboard, using a local “MyPassportWirelessGen2_1.03.04.bin” file (with this exact filename), which I downloaded from WD Support to the Downloads folder of my notebook. During this update process the notebook stayed connected to the 5 GHz WiFi network of the drive. No other 5 GHz networks in operation. The notebook was only 5 feet away from the drive. Battery status was more than 80 % both on the drive and on my notebook. The upload of the firmware to the drive never ended. After more than 60 minutes I reluctantly powered down the drive and did a manual reset to factory settings and a manual firmware update to v1.03.04 using an SD card with the “MyPassportWirelessGen2_1.03.04.bin” file sitting in a “update” folder of the SD card. The SD card was inserted to the drive while powering up. After that firmware update to v1.03.04 (which completed successfully) there were “2.7 TB Free” shown in the Dashboard. 2.7 TB instead of the expected 3 TB that were shown with the original firmware version. The file content on the drive did not change however. How is that possible?

Kind regards,
Alex

Sorry I didn’t address everything at once. To your question regarding capacity, The display was fixed with the firmware update. It should have always displayed 2.7TB. This has to do with how a drive capacity is read. This article explains the capacity discrepancy.

This pertains to both internal and external drives.
The initial failure of the firmware update may have caused issues with the WiFi.
If possible, can you connect to the dashboard again, this time try the firmware update form a file on the laptop rather than through the SD card?

Thank you for clearing things up regarding the 3TB vs. 2.7TB capacity display issue. So my question regarding this would be: Is it possible to get roughly 3,000,000,000,000 bytes free on my drive, after having fixed my firmware problems, of course? Or, probably due to some mandatory system files stored on the drive, is it possible to get at least roughly 2,999,000,000,000 bytes free? I would like to use the disk as a mobile backup solution for the SD cards of my film equipment on the road only. I do not intend to use any Plex Media Server functions. What folders on the drive may be emptied for that matter and how can I make sure that no unneeded housekeeping will be done? And is building a DLNA database really needed if I only want to sporadically check the error-freeness of the backup of my photo or video data on the road, streaming some files with my wirelessly connected smartphone?

With respect to my initial failure of the firmware update, I am a bit worried that my new drive has a hardware problem. At a distance of only 5 feet the firmware upload to the drive did not finish even after 60 minutes. Maybe I only have a corrupted firmware state now, so I would like to wipe my drive clean. Is there a possibility to completely erase everything currently stored on the My Passport Wireless Pro, maybe by reformatting it (exFAT) and starting fresh from the v1.03.04 stored on a SD card? What will be the benefit of updating wirelessly from a file on my laptop (my first attempt went nowhere)? Is it safe at all to update wirelessly?

Kind regards,
Alex

You can perform a full factory reset which will remove Plex andreformat the internal HDD back to EXFat. the 2.7TB is all the space you will be able to use. This is the same as a standard 3TB drive. There is nothing else you can delete to get that space. Turning off the meda server will stop the media from indexing and save some space. I suggested updating from a file on the laptop in case the initial firmware failure may have caused additional coding issues that might effect reading from the SD card slot. This is all hypothetical. You could try it either way and if it still isn’t operating correctly, I would get it exchanged for a new drive though the retailer you purchased it from.

Is the “full factory reset”, which re-formats the drive to exFAT, already triggered by holding down the Power and WPS buttons for appr. 10 seconds or is it only available from the Dashboard? Which means: Will holding down the Power and WPS buttons for appr. 10 seconds (while the unit is on) only change all administrative settings back to their default values, return the administrator password to none and rename the drive to MyPassport, so all my media files stored on the drive would definitely remain intact? The latter would be an invaluable emergency feature, if for some reason I cannot wirelessly connect to my drive while being on the road.

After I have done a full factory reset, re-formatting the drive, can I instantly connect the drive via USB 3.0 to my PC and run “WD Drive Utilities for Windows 1.4.0.92” in order to physically check the My Passport Wireless Pro?

Thank you.

Kind regards,
Alex