Wireless Network won't work - please help


#1

I am expriencing a similar issue. I am using a Netgear DGN2000 Wireless Router and a D-Link Wireless 150 USB Adapter DWA-125 which is listed as compatible. My device picks up my network with enough bars. I can then say connect auto or manuel and it says network setup complete. When I run the network test option it tells me no DNS found. I have also tried the hardwire route and get the same result.

Any suggestions?


#2

That will happen if your Internet Router (which, I am assuming, is also your DHCP server) does not provide a valid DNS address with the IP configuration.  

In my case, the DNS address is the SAME as my Default Gateway (because my router acts as a DNS proxy.)


#3

I have thought about this further. I currently to not have a DSL connection. My router is set to get DNS from ISP so that would explain the DNS error (I think).

But I should still be able to connect to my wireless network. I have done so with several other devices including laptops and mobile devices, all successfully.

The WD Live still sees my network but when I tell it to connect automatically it cannot obtain IP address and subnet information? When I put it in manually and run the network test it does not complain about the IP address but only the DNS (which I believe is explained above). Then I should be able to see my network after that but I cannot see any devices?

I thought it might have been a firewall issue on my router so I opened all ports to test and still the same thing.

I am not sure what else I can try now??


#4

The DNS IP address is the same as the Gateway IP address in this instance. Typical DHCP setup.