Wireless N Nano USB adaptor compatability

Good day

First let me say thank you for any help before I ask my question. I have a WD TV Live HD Media PLayer , I bought a D-Links DWA-131 Wireless N Nano USB adaptor. When I strive to install it on my Media Player it will not recognize wired or wireless as the instructions indicate. I can get it to work on my laptop.  Could it be the box itself and it’s USB connector, but I did try both of them and got the same results As far as I can tell it is on the acceptable USB wireless list. All I want to do is to be able to stream the content from my harddrives. Thank you again


If it’s a different hardware revision than what’s listed on the sheet, it might not work.

Also, you must be running the 1.02.21 code on the Live.

i have dwa-131 usb adapter also. i can see both wired and wireless network but after i input the SSID, it says “Unable to obtain the ip address. The media player has limited or no network connectivity”. i even upgraded the firmware to 1.03.39_B and still no help. only problem that i may see is that the manufacturer had changed the chipset after WD tested. i should’ve done some research before i purchased this adapter last week. it’s too late for me to returned since the box is trashed now. it seems like only way to solve this is to get 100’ ethernet cable… lolz

You could try the following:

reset via the side paperclip button

reset to factory defaults via the internal menu

unplug from power for some minutes (not seconds)

Do all 3 one after the other

Now try the wireless connection setup again. Use the auto facility.

After you put in the SSID, it should ask you for the security key or password.  It’s not doing that?   Are you running your wireless WITHOUT security?  (If so, Shame Shame!)

hi there. thanks for the replies… i got back to this forum to search for which wireless adapter works!

i tried all the resets and still not working.

the message, “Unable to obtain the ip address…” is after i input the security keys.

i tried so many times, i even memorized it… lol

this usb adapter is fast when i tried on the desktop. i have no choice but to put in the drawer…=(


That guarantees that the WDTV will negotiate security parameters correctly.

When you go to wireles, have it SCAN for networks.   You should see your SSID listed.  Select it, and it will ask for the security key.

If you do NOT broadcast, you will have to manually type your SSID, then choose the security type, then the key.    More room for error.

wired networked didn’t work for me either.

i updated the firmware of my router, which is Linksys WRT54GS, and then it’s working great!!!

thanks for your help tho…=)