Wireless devices have issues with Wi-Fi when WDMC is attached to network


Users’  devices keep disconnecting of Wi-Fi for half minute and reconnect again, this issue occur every 30-45 mintues when only WDMC is attached to network(modem), tried other ports on modem, reload both WDMC and modem, I also tried to connect WDMC to switch and then from switch to modem with no luck.

WDMC firmware is up to date v04.01.03-421 (2TB)

Appreciate any input to solve this problem.

Thanks in advance.


Have you got cloud access enabled?

Have you got automatic firmware upgrade enabled?

Are any users accessing the media server?

In other words, is there any reason why the MyCloud should be dominating traffic on your network?  Not that this should cause devices to disconnect…

Is anything odd happening with IP addresses on your network?

I have a feeling I’ve seen this reported before.  Have a search in the forum.

After a while of disabling/enabling features in MyCloud the only feature which cause this problem is CLOUD ACCESS.

Now Cloud access is disabled.

All other features like Auto firmware upgrade/iTunes server/ mac backups/media stream all of them are enabled.

Is this issue happened to anyone else???

You need to log into your router and set up a reserved IP address for your WDMC. This should be outside the range of the DHCP server.

Firstly, login to your WDMC dashboard. Under Settings - Network - select Network Mode - DHCP.

Next login to your router dashboard. Under LAN settings look for the DHCP pool settings. The DHCP start / end range is probably set to to Set the end IP address to Then manually reserve an IP address above for the WDMC, e.g. You will need to specify the MAC address of the WDMC in the router interface so that the router knows which device to assign the IP address.

dubie thanks for your replay but this is actually my setup and still i have the problem

my setup before OP & currently as follows:

Alcatel Fiber Router w/ wi-fi disabled (wi-fi not stable) and dhcp enabled range

Netgear Modem works as Wireless Access point attached to the router

WDMC attached to the router

Netgear repeater taking ip address from dhcp range

cpt_paranoia   I tried digging in the forum to find a similar thread wth no luck.

below solution seems working flawlessly (BTW I have W7 64-bit) - previuos setting was in Auto Connectivity mode (by default).