Wiped drive, now I can't find it

I have a WD1200U017-002. I wanted to lend it to a friend, but before I lent it out; I wanted to make sure that ALL information was wiped from the drive.

I used Darik’s Boot and Nuke (DBAN) hard drive wipe utility (boot disk), using the quick DOD wipe (5 pass write). It completed successfully after a few hours.

I then moved the drive to a windows PC. It wasn’t recognized at all. I checked the Disk Manager utility in Windows, and it too didn’t recognize the drive. It doesn’t show up in Hardware Manager either. So I’m not sure if I deleted a hidden partition on the drive or something like that.

I tried plugging it into a Linux PC, but it didn’t recognize the drive either.

So what would I need to be able to see this drive again? Once I can see it again, I’ll be able to partition/format it. Maybe try a Win98 boot disk with Fdisk?

Try using another USB cable and avoid using USB hubs.


I had forgotten that I had posted on this web site.

I posted the same thing on Computing.net and got 4 replies within an hour or two. I also got a solution that worked from there.

The problem was with the USB port that I used on the MOBO. It had too low power to be able to recognize the drive. Plugged it into a different port that wasn’t shared, and it was recognized immediately.

The drive has been partitioned and formatted, and is being filled with files already.

Thanks for the reply though.