Windows7 folder sharing with WDHDLIVEPlus

WDHDLIVEPLUS can’t access my windows7 shared folders.  Any suggesstions regarding how to do windows7 folder sharing.  WORKGROUPS are same.  

Here is a check list to follow to make sure the shared folder can be accesed 

Must be a home grade router present in the network

Having UPnP enabled on the router is recommended, and may be required for proper connectivity with other network devices

To check connection go to Settings>Network Settings> Check Connection

If the check connection fails reset the unit

To reset the WDTV physically hold down the reset button on the side where the USB port is for 4 seconds and release

Depending on your network’s configuration you may need to disable or adjust your Firewall settings in order for your shared folder to be visible on your network. Please contact your Firewall manufacturer for assistance doing this

  1. The first thing you will need to do to allow folders to be shared with the WD TV Live is to determine how your network is configured. Follow the instructions below to determine what kind of network you have.
  2. From your Control Panel select Network and Internet
  3. Select the Network And Sharing Center option.
  4. Below the name of the network (near the top of the window) look to see if it is a Home, Work, Public, or Domain network
  5. If your network is set to Work, you will not need to make any changes to the type of network you are on.
  6. From the Network and Sharing Center click on the Choose homegroup and sharing options link near the bottom of the window.
  7. Click on the Change advanced sharing settings… link.
  8. Ensure that the following options are selected: Turn on network discovery, Turn on file and printer sharing, Media streaming is on, and Allow Windows to manage homegroup connections (recommended)

The option “Check Connection” report “Ok”. But, none share folder is visible. The WD TV Live Plus report “No storage present”. Verifying the network by Wireshark, occour problems in authenticate process: Session Setup AndX Request, NTLMSSP_NEGOTIATE Session Setup AndX Response, NTLMSSP_CHALLENGE, Error: STATUS_MORE_PROCESSING_REQUIRED Session Setup AndX Request, NTLMSSP_AUTH, User: GROUP\GUEST Session Setup AndX Response, Error: STATUS_LOGON_FAILURE Session Setup AndX Request, User: anonymous


I can’t be sure without looking at a CORRECT login process, but I’m wondering:   Do you have password protected sharing ENABLED on your Win7 network profile?   If so, that’s why it’s failing with the user “anonymous”

If that’s the case, then go into the WD’s NETWORK SETTINGS and turn OFF “Auto Login to Network Shares”

Then you should be able to log in.

After a success, you can then return to the setup and turn “Auto Login” back on, and the WD will remember the last login you used.

I found that it won’t share out by just selecting Anyone or Anon, you need a password protected account.  I created a unique local username on the Win7 PC, in this case, WDTV, with a simple password.  Then click on the folder you want to share out and add WDTV as a user who can access the folder.  I only allow read access just so the WDTV can’t accidentally change anything.

Then on the WDTV, select the PC with the shares and it should ask for a username/password.  Put in the WDTV username and it’s password.  If you want, you can set the WDTV for Auto Logon as noted above.

I should also note that the PLUS unit has a problem with playing shared folders from network drives/PCs.  The video stutters and is basically unusable, so even if you do get it shared out correctly, it may not work very well.

However, music files played thru shared drives works just fine.