Windows XP can't read my My Book


I am extremely frustrated. I originally had this WD 5000 (500GB) backing up my HP Vista laptop (with no issues), but  I cannot get my older XP Desktop to read the drive.

It shows the usual symptoms- appears as a USB device in the Tray, can’t be seen in My Computer, but can be seen and opened through Manage/Computer Management, etc.

Here is everything I have tried to date besides throwing the **bleep** thing out:

  1. Uninstall and reinstall the MS drivers (upon reboot it then picked up that it was a WD My Book Drive but still not read by My Computer)

  2. Go through Computer Management and add as a drive (multiple times, never appeared in My Computer)

  3. Tried some suggested Registry hacks (delete High filter & Low filter)

  4. Turn off the 1394 Network Connection

  5. Try using a USB conection in the back of the computer

None of the above have worked. I can see the drive through Computer Management, but when I try and copy the files from my C: drive to the named drive (the WD external), it tells me the “destination drive cannot handle long file names” which baffles me because it’s listed as an NTFS drive which is designed to handle the 256-character names (which they do not exceed).

I already have files on the drive, so I am not thrilled with having to copy them to onto my Vista laptop and then try and re-format the WD, esp. since I am not confident that it will work.

Any new suggestions based on the attempts I have already tried listed above?


-Steve C

Dear iccohen, greetings from Rio!

My two MyBooks 500GB (model WD500C032, serial numbers WMAPW1227969 and WCANU1529392) died after some years use. Windows XP simply stopped recognizing them. The cause may have been high temperature. Yesterday I opened both units, extracted the hard disks and installed them back to the computer using normal HD cases. The disks are 100% OK, all data is safe. Calm down and give it a try. Instructions here —

Best wishes.

On service,

  • c.a.t.

I solved the problem, but it was by doing something that was a bit odd.

I found a link where someone was having the same problem I was, where previously when I had attached external storage I would receive a generic volume message telling me to contact the vendor.

Here is the advice. It worked for me, non more messages, everything can be read -  worth a try for others…

_Hi. I started getting the same error message when I tried connecting a PNY Flash Drive to my USB port. Here’s what worked for me. This may be unique because I caused the problem myself.

Like many people who are trying to speed up Windows or slim down files or tweak this and adjust that, I use some (not so reliable) hints and tips I have read. I followed certain steps posted at an url called “How can I delete undeletable folders?”, wherein a poster named “********” gave instructions for removing Netmeeting, MSN Gaming Zone, Xerox, Movie Maker, and Microsoft Frontpage from the Program Files folder. Seemed like a plan to me. But then, as I recall, Custer had one, too. Unfortunately, blindly following his advice and renaming SFCFILES.DLL to SFCFILES.OLD and then removing these folders in Safe Mode caused the “device installer error”. I deduced this by restoring the system day by day backwards until the error messages went away. Renaming SFCFILES.OLD back to SFCFILES.DLL and rebooting XP made the folders come back and the error messages go away. My Nikon D70 is back and the PNY Flash drive loads just fine, thank you very much._


Woo Hoo!!!