Windows Update error 80073701 8050800C

Hi All,

On some of ours DX4000 Sentinel the Windows Update process looks stuck as all the latest updates are recognized but not installed and different errors are reported, like e.g. 80073701 8050800C after giving the install command.

I already tried getting rid of all the softwaredistribution folder to restart from scratch but nothing changed

Any idea?

thanks and regards


seems like there was one update that would help, but not sure if this is it or not. The other idea is running disc cleanup

I have noticed that updates seems to hang, but after a reboot it has stuff to install

on one unit the trick of selecting “Shut down and install” did the trick (instead of using install from windows update).

On the second one I tried using cleanup but now at reboot is stuck since a few hours showing a message "Please wait for the Windows Modules Installer”. Looking at some previous posts I hope it will be just a matter of being patient.

… and another update which was not correctly installed with WU, was successfully loaded forcing an update on Windows Defender. WU is a weird world…