Windows shares not working

1st off I’ve searched all of the forums everywhere and tried almost everything to resolve this, but here i am.

I’ve had my WD tv live streaming toy for about 18 months with no problem. 

as of 2 days ago, my apple tv gen 3 (which i only use for the TENNIS TV app) dropped off the WIFI and i couldnt get on. i can still see the WIFI network but i can not connect.

i then tried my WD and i couldn’t connect to the windows share feature which i have been doing the whole time. I’m actually connected to the WIFI network, but i cant connect through the Ethernet  cable?? what the **bleep**??

i then jummped on the net to furiously fix this.

i can still see the wd and the connected thumbdrive on my network on the desktop. which is doing my head in. ive tried restarting and reseting both modem and the WD’s with no avail. i also tried to roll back my firmware on the WD, it said it was upgraded, rebooted then tired to install the firmware again off the thumbdrive??

also checked my desktop was the master browser too… boo

im using the old 2003 xp if this helps. ive looked everywhere, to fix this. if anyone can help thatd be good.



Make sure that the folders are properly shared on your network.

Also see if this helps.