Windows share works with Windows 7 but not with Windows XP

I have done a search but, even though I found lots of similiar posts, didn’t find an answer  :frowning:

Firstly, I have a WDTV Live SMP which works PERFECTLY on my Windows 7 desktop and laptop.  I am so happy with it I recommended it to a friend.  My friend has a Windows 7 laptop and a Windows XP desktop and lives a 20Km drive away (so I can’t just try things quickly)  :frowning:

My friend would like to stream videos from his main system, the Windows XP desktop as it has his main storage.

Anyway, the problem…

I created shared folders on both 7 and XP systems.  Switch everything on and wait…

Then select Videos then press the Red Button then Network Share then Windows Shares, both computers display for selection.  All good so far?  This suggests to me that the WDTV SMP sees both systems…

I select the laptop and the shares display for selection - PERFECT (as expected)  :slight_smile:

Select a movie - it plays   :smiley:

I select the desktop and it shows the Anonymous login screen.  Pressing OK, OK on the login screen doesn’t work.  Trying the User Name login doesn’t work.  :frowning:

Nothing keyed in at this point works   :(   :(   :frowning:

Although I’m computer literate (40 years retired mainframe analyst/programmer) I am not comfortable with Networks etc.  :(    We had a Sys Admin to do all that stuff…   :wink:

I hope the fact that the laptop does NOT ask for a login and the XP system DOES is meaningful to you smart people out there in the Community.

My friend also bought an Android media player box and couldn’t get THAT to connect either.  A cleverer friend had a play with THAT and couldn’t get it to work so we were expecting problems before he bought the WDTV SMP.

Hopefully this brilliant Community can help.

Admittedly, I haven’t checked Workgroup names etc but I can’t see my friend playing with that at setup.

Thanks In Anticipation   :slight_smile:

Wow !  “Smiley Face” overload …

Sorry, very “Smiley Face” kind of person    :)    :)    :)    :)    :slight_smile:

Any thoughts about the problem?


Well, with regards to Network Shares in XP to WDTV …

i was having trouble with my WDTV Live Hub WinXP Network Shares …  the below *Fix* solved my problem

(It should also be relevent to the Live Streaming as well)

It would appear that if you want to connect your WDTV Live to your PC’s Shared Folders you need to ensure that the services “Network DDE” and “Network DDE DSDM” are not disabled.

To do this: Start Button, Administrative Tools, Services, locate “Network DDE” and ensure that Start Up Type is “Automatic”. If it’s shown as “Disabled”, right click the “Network DDE” entry and use the Properties Tab to set it to “Automatic”.

Then do the same for the “Network DDE DSDM” service.

Reboot your PC

My additional info … On the Live Streaming … Setup > Network Settings > Clear Login info for Network Shares


Then navigate to Videos … press the RED source button on the Remote and select “Network Shares”

and Hopefully it will work for WinXP now.



Info Source:

1 Like

Thanks for that.   :slight_smile:

As you can imagine it makes no sense to me whatever…    As I said - raving newbie to networking here.

I will try to follow your solution on Sunday (next time I see my friend).

Everything appears to already work for Windows 7 though?

Thanks again   :slight_smile:

No probs louwin

I don’t use network streaming of content much at all, but sometimes it’s nice to have (and to work)

Long live “Sneakernet” :wink:

Hi Joey,

I made the 2 changes you specified, changing the unenabled to Automatic and rebooted the XP system.  I Also checked the workgroup name while I was at it.  It was WORKGROUP as expected.

With bated breath I cleared the shared login info (after cold starting the WDTV). Videos - Windows Shares - MAINPC and it displayed the anonymous login screen.  Again NOTHING entered was accepted   :frowning:

I brought my friend’s WD TV SMP home and swapped it with mine.  Selected MY network and password then selected MY PC.  IT BROUGHT UP THE ANONYMOUS LOGIN SCREEN!!!  (Unexpected)!  :frowning:

I entered my account name and password and off it went…  PERFECT…

Selected my NAS and it showed the anonymous login screen (as expected).  Ok, Ok and off that went…  PERFECT.

I didn’t expect the login screen on the Windows Shares but it worked so okay!

Thanks for your help but sadly, your solution didn’t work    :frowning:

Any more solutions?


The problem has got to be XP but what?  :frowning: