Windows Share on Windows 7 not working

Let me preface this post with the fact that I’ve scoured these boards for information regarding this issue and have tried multiple things to no avail.

I recently purchased the WD TV SMP and was able to get the Media Server running right out of the box, but have been unable to get the windows share option to work. I can read the shared folders with my playbook, laptop, ipad and mac though.

Any help would be greatly appreciated

Have you tried this?  How to share a folder in Windows that can be viewed with the WD TV Live, Live Streaming, Live Hub, or Live Plus 

You may also reset the SMP, by holding the reset button for 1 second, and try using a second computer, in order to compare results.

I’ve had intermittent issues with my WD Live device seeing my network share. Sometimes it would work, sometimes it would not. The share is always visible from other computers on my network.

I think I may have narrowed down the problem: if my network’s Master Browser is set to a computer other than the computer hosting the shares, the WD Live device has issues connecting to it.

I could not connect to my /media share this morning from the WD Live. The network’s Master Browser was set to my wife’s desktop. I shut down the Computer Browser service on her machine (Control Panel -> Administrative Tools -> Services; click on “Computer Browser” and select “Stop the service”) , and my son’s computer became the Master Browser. I shut down the Computer Browser service on that machine, and my machine (which hosts the /media share) became the master browser. I don’t know what the analgous steps would be for a mac device.

To determine which computer was the master browser, I used the script posted here: http://scottiestech.info/2009/02/14/how-to-determine-the-master-browser-in-a-windows-workgroup/ – Andy_D posted it in this thread.

On my machine, I opened a command prompt and typed NET VEW. At first nothing appeared in the box; I opened Windows Explorer and navigated to the network to force a refresh. Trying NET VIEW  again this time displayed the seven devices on my network.

I rebooted the WD Live device, and upon navigating to Network Shares, I could see every machine on the network, and could connect to all shares.

I suspect the transitory nature of the Master Browser might explain some of the weird behavior people are reporting, with share sometimes working and sometimes not, and why different amounts of voodoo sometimes fix the problem – or at least make the thing start working again.

Please let us know if this helps.

Of course, you should first be sure your network settings are configured correctly. I followed the steps outlined in the youtube video referenced in this post by Mutt72 when I was first setting up my device some months ago.