Windows Share no longer found after upgrade to 2.01.86

I want to roll back to an older version where can I download the last firmware up grade before 2.01.86?



I have the same problem.

WiFi connection checked, same IP-address assigned to WDTV as before, Internet connection works.

Windows share is not found. The share was found minutes before the upgrade.

There are no other explanations than a bug in version 2.01.86

Please fix this or provide a method for rollback to previous version.

If you want more immediate help in the future then please post in the main forum.

You would have been told very quickly about the rollback page as it is common knowledge.

Have you tried resetting to factory defaults within the setup menu and unplugging from power for a few minutes.

Same problem here. No Shared folders can be found on any of my network devices including two PC’s and a NAS.

Please Fix it! :frowning:

Oh yay!

After rolling back to the previous Firmware using the tutorial provided by richUK (all went fine), I can see all the network devices again, but I can not login anymore. It always tells me, that either user or password are incorrect. I tried to delete all the information in the network settings, changed the passwords on the PC’s and did a factory reset on the WDTV, nothing helped.

Thanks for this BRILLIANT software update, that kept me busy for several hours. Tomorrow I will return the WDTV to amazon (have had the thing for less than 2 weeks and get something else. Good job on quality testing your FW-updates, Western Digital.

Had the same problem.

Go to Setup

Go to system

Go to Device Restart Press Okay

I rolled back to version 1.15.13 and it still didn’t work!!

No windows sahres found ie little round arrow around and around forever!!

But the Device Restart did the trick.

NOT device RESET… Device RESTART

Good Luck!!!


Did you remove power for some minutes, which would I assume would  make it the same as a system restart.

Don’t know whether this will help, but I seemed to initially have trouble getting to my Network Shares. Try pressing the RED(B) button on your remote and go from there. Don’t know why, but it worked for me. Worth a try.

Just so there is no cofusion, it’s the Red  “B” key, …not the Red Power on/off one.