Windows Server services fail to start

I have a WD Sentinel. I bought it after a horrendous loss of data with an ASUS NAS. It worked wonderfully for many years. A year ago a hard drive failed. Although ti was a massive hassle to get a replacement I got one through WD in the end. However I realized over time that the machine never really recovered from that day. My current issue is I cannot get anything to really work the way it should It appears that none or the WB service now load (LCD screen etc), the time and date on the NAS are never correct after I log out and log back in though I have reset it time and time again and none of the dashboard programs work. I am not sure how to fix this. i am looking for advice.

Do you have a DX 4000?
I have seen the date be off when it is shut down, but not go wrong when set and up and running.
DO you have any of the issues in this thread?

Yes its a DX4000. I will have to make time and work my way through that thread and see. Thanks for now.

Hello - I have the same issues - both Date/Time on power cycle and the computer monitoring issue as referenced. I worked through registry changes and outside of the model number, everything matched, but I cannot get many of the Windows and WD Services to start on the DX4000. I do have remote desktop setup and can access the device ok.

The device was running fine 2 weeks ago, shut it down to move it temporarily to allow for some work to be done in that room and booted back up a week later with all the issues mentioned above. I’m to the point where I think I need to just recover the unit - but I’m concerned with the reliability of recovery.

How stable it recovering the unit and keeping the Raid data partition intact? I know were dealing with computers so there’s always a certain amount of risk involved… just wasn’t sure if anyone had a comment on it’s stability.


Are you sure the date is correct? The services should start.
To be honest I have never personally done a recovery keeping data, but others have and say it works fine. The simple solution is to back it up first :slight_smile:

Thanks Gramps,

Yes to the time, I’ve gone into Date/Time and sync’d with windows time server.

I get errors such as The dependency service or group failed to start for many of the WD services - and when I shift to those dependancies (working my way up the ladder so to speak) - I get to Windows Services and get errors such as The process terminated unexpectedly.

So my next step was to look at Event Logs, and many of the Application Errors list SharedServiceHost.exe as the issue. Hence my assumption that the OS is corrupted from shutting down last week. Which should have been a clean shutdown (1 press on the front panel).

In regards to backing up - about 1/3 of the 8TB on device is backed up, elsewhere. 1/3 are backups that I could recreate and the balance is all archived data not backed up elsewhere (we’ve been planning an offsite backup with S3 - just haven’t gotten there yet).

the date, not the time :slight_smile: