Windows Server Backup + Shared Folders

Hi there!

I have a big issue with my WD Sentinel DX4000. Yesterday I was finishing setting up my replacement DX 4000 when I joined my machine to my Homegroup via the Dashboard. This operation got stuck in “Sharing folders…” for nearly 24 hours, so I decided to close the Dashboards in order to kill the process.

Later on, I tried to do a first back up of the server, so I opened Windows Server Backup, and noticed it gets stuck in “Reading data; please wait…” That got me worried, so I started checking things on my server, and then noticed an issue with the shared folders on the Dashboard—if I check the folders’ properties and go to Sharing, I can see the error “Cannot retrieve user access level permissions for the folder.”

I decided to RDC to the server and stopped sharing one of the shared folders from Share and Storage Management. Then tried to recreate the missing Shared folder from the Dashboard, but the Dashboard gets stuck creating the shared folder. It seems the Dashboard doesn’t communicate properly with the server.

Last months have been tough getting my old machine to work properly… Now it seems I’m going to have to recover my replacement DX4000 just after setting it up. Any help?

I think I would shut down and restart the box
Then make sure the date is correct, not the time, the date
Make sure the windows server services are started
open windows explorer on the server and make sure all the files and folders are there

then read this :smile:

I have shut down and restarted the box.

The date is correct, also the time.

All Windows Server services were started, but two:

  • Windows Server Initialization Service (Startup Type set to Automatic) — I have started it several times, but turns itself off
  • Windows Server Server Backup Service (Startup Type was set to Disable, now to Automatic) — I have started it, and it remains started. The problem with Windows Server Backup remains also after starting this service

All of the files and folders are there, I have checked them from Windows Explorer inside the server. I can also see them from my computer under the Network tree. If I log into the server via Remote Web Access, the Shared Folders group reads “There are no shared folders on your server.” However, Pictures, Music, and Videos shared folders are shown in the Media library (?).

I’ve just finished doing this. I’m on the step 7, but I don’t know when the CurrentDatabase_ file will be finished. Any tips?

I have followed all the steps, restarted the server, and the problem persists… Recovery?

Sorry I was on the road and apparently the mail to reply did not work

I think I would go through those steps in the other post one more time.

But I am also going to suggest you just leave media streaming off on the box. It is not that great. serviio or plex works much better

Thanks for the suggestions, Gramps!

I tried one more time, but didn’t work either… Leaving the media streaming off doesn’t solve the problem either :frowning:

Also, there is the issue with Windows Server Backup…

I would not use the shared storage Managment, whatever instead of the dashboard.
In any case I think it is choking on a file somewhere.
Whatever you want to do. reload it, or perhaps remove the media files and folders, and recreate them from the dashboard.
Turn off homegroup?

Turning off the Homegroup was the first thing I did before starting this topic.

I tried to stop sharing folders, create new folders, etc. from the Dashboard, but all the processes get stuck on 0%.

I have decided to perform a recovery. Now the machine has been 30 minutes in “INITIALIZING OK. LOADING RECOVERY.”

Let’s see what happens now. This machine makes me crazy…

I was going to delete the media folders from windows explorer. Kill them off, then recreate from the dashboard. But recovery will work also

Now the machine has been nearly two hours showing “INITIALIZING OK. LOADING RECOVERY”

Is this normal? How long can it take?

you should still have the pc connected. What does it say? It does take 3 or 4 hours. I forget what the LCD actually says when it is working.

The PC is still connected, this is what is says:

To start the WD Sentinel server in recovery mode:

  1. Shut down the WD Sentinel server.
  2. Insert the USB flash drive that you prepared earlier created into one of the server’s USB ports.
  3. Restart your server by pressing and holding the Recovery button on the back of the server (up to 30 seconds) until one of the following messages displays on your device LCD or monitor.
  4. Then release the Recovery button. Leave the USB flash drive connected to the WD Sentinel server.
  5. The monitor or LCD displays “RECOVERY INITIALIZING.”
  6. When the monitor or LCD displays “RECOVERY STARTED,” return to the computer.
  7. Click Next to connect to the WD Sentinel server and follow the instructions as prompted.

To learn more about the special USB port, see the WD Sentinel Administrative Guide provided with the product.

So I’m stuck in Step 4, waiting for the server to read first “RECOVERY INITIALIZING,” and then “RECOVERY STARTED.” Only then I can click on Next on my computer to continue with the server recovery process.

Now over five hours have passed since I turned the server on on recovery mode…

Does not sound like it is working. Most common problem is a bad download. On the old WD support page it had the checksum to verify the file. Since WD pulled the files and no one returns my emails, I dunno

That’s weird… The ISO I’m using has worked in the past with my old DX4000. What should I do? If I shut the machine down, the RAID system may have to be rebuilt once I turn the machine back on, right? Do I have any other option?

You do have a dhcp server on your network? Though if you did not I think the error would pop up later.
Yes if the ISO worked in the past I would think it would be good, unless it made a bad thumb drive. Not sure what date download you have but I did find the hash files but the downloads do not appear to work for me. You would need to find the proper page in the link below to get the matching hash

Your call, wait or power off. If you power off, you might see if it will boot back up and we can just try to clean up the shares

Not sure what a DHCP server is, so I’m guessing no :slight_smile: The DX4000 is the only “server” I have on my network.

The ISO I have is this one—EMEA_SvrRecovery_1_7_5_17.iso

How can I check if it’s a good download? I’m sure it is, but I could double-check.


Your router is probably the dhcp server.

  • I Think * this is the correct hash
    // File Checksum Integrity Verifier version 2.05.
    46649c0b8acca02c6544514e5c99bd4c emea_svrrecovery.iso

You use something like this to check it

Thanks, it’s a good download, probably the thumb drive is bad.

The recovery is not starting, I’m going to leave it overnight and I’ll see what I do tomorrow morning.

I’ll probably have to power it off…