Windows Security ... Files Might Be Harmful

I have the 3TB WDBCTL0030HWT My Cloud drive on a Windows 7 desktop, and accessed by both Win7 and Win8 machines remotely.   It works fine for the most part, but any time I try to move or copy a file using the mapped drive, I get the Windows Security prompt “These Files Might Be Harmful to Your Computer - Your Internet Security settings suggest that one or more files may be harmful.  Do you want to use it anyway?”

This pretty much makes file manipulation on a mapped drive impossible, and I would like to find a way to permit this device/service without the prompt.  This is obvioiusly a common issue, but I’ve yet to find a solution (either from Google or trial/error) that works.  Here’s what I’ve tried:

-Adding to the various security zones in IE, testing each by completely disconnecting the map, logging out of wd2go, closing browser, and then logging back in, mappind drive, etc.

-Did the above using various iterations of wd2go (http and https) and also using the convuluted string shown in the mapped drive name, just for grins.

-Lowered the security level sliders in IE. (disconnected, logged out, etc.)

-Turned off Windows Firewall, just to test. (disconnected, logged out, etc.)

As mentioned, I have searched on this issue and all of the results I have found have either not worked or not been exactly the same problem. (for example, a lot of folks are being prompted for a password…I am not)

I got into this after all the April mess so I’ve found the drive to work fairly well.   I don’t like the fact that I cannot connect to it directly to move files via eSata or USB3, so getting my data onto the device has been the first hurdle.   Now I’m trying to *use* what data is on there so far and this prompt makes it almost unusable.  Obviously the client works well, but I cannot have that with me everywhere.   The web interface also works well…no prompts…but also no previews.  So quickly sorting/moving photos is virtually impossible.

I appreciate any suggestions/solutions.   Thanks!  Doug

Use the Snipping tool to save a image of the security prompt you are getting and then post it here.


Is there a box where you can choose not to see this prompt anymore?


Posted by,
cat0w (USA)



-There is no checkbox.

-Clicking the down arrow on “Show Details” simply shows the path that is being referenced, i.e. G:\Folder1\Subfolder1\  and nothing else.

-Clicking on “How do I decide…” just opens Windows Help about general file security and what the prompt is warning against.   Nothing regarding how to prevent the prompt, other than referencing IE security I believe. 

You said above that you tried adding wd2go to IE’s security zones, but did you add it to WINDOWS security zone?

Yes, the link you referenced points to “Internet Options” under Control Panel, which is the same security dialogue box that IE points to.

And to avoid arguments about the truthfulness of that statement, I endulged and followed that path…and the URL was already populated in the security zone.

Thanks for  your reply.

Here is another link for you to try. Hope this information will help. This was found doing a Google search using, “These files might be harmful to your computer”.


Posted by,
cat0w (USA)