Windows only detects one of multiple WD My Book World Edition II Drives


#1

Hi everyone, I’m hoping someone can help me out with a fairly frustrating issue that I’m having with these WD My Book World Edition II hard drives.

I have 3 WD MBWE II’s that I connect to my router (D-Link DIR-655)  via network cables, which are all detected by the router and identified properly as three separate drives via their MAC addresses. However, Windows 7 or Vista (both x64) can only detect 1 of the 3 drives (whichever of the three drives is connected first). The drive appears in the Network as “MYBOOKWORLD,” regardless of which drive I connect to the routher or even if I connect the drive to my PC directly.

The WD Discovery Software failed to detect any of the drives even when Windows was detecting one of htem.

Can anyone suggest how I can ensure that all three drives are detected properly and under different names?


#2

Plug everyone at a time, change the name of the second to mybookworld2 and the 3rd mybookworld3 , then connect all together , and you will be good to go . Cheers


#3

Windows doesn’t allow me to rename the drive once it is connected.

The only options available are Open, Explore, or Create Shortcut.


#4

finally started working once I was accessing the drive through Windows and also hitting refresh on the IP over and over.

Being trigger happy seems to have done the trick.

Thanks a lot for the help.


#5

oh ok, glad to hear that, but anyways not to have any conflict , you may need to assign different names to the drives, by going to the network storage manager.


#6

I agree with the other person who posted.

Open a browser like Mozilla/InternetExplorer/GoogleChrome

Login in to each device by typing the ip address in the url address section

example http://192.168.1.1

By doing this you can do the following which will be very helpful

  • Rename the each device to have a different name
  • Set all devices to have the same workgroup…also, make sure you pc’s or macs have the same workgroup…this helps the each pc and mac from lossing connectivity when they are all in the same workgroup or domain
  • Enable AFP/FTP/NFS/CFIS as needed…afp lets you connect with macs to storage quickly ftp is good for external connections
  • Create a username = to that in your pc or mac with the same username and password so you don’t have to have multiple usernames and passwords…plus pc’s are picky and like it when you do this
  • Don’t forget to add the account usernames to the Admin Groups on all devices

Those steps should help you from having to every search for you devices, and will guarantee they are present under NETWORK CONNECTIONS at all times!


#7

I also have three 1tb white lights (and four blue rings) and had the same problem.  I had three icons in Windows Explorer which showed up fine under Network but when you tried to connect you could only connect to the last connected drive.

This is what I did to get it to recognize them in Windows 7 64 bit.

In Windows Explorer

  1. Go to Computer/Network Location
    Right Click anywhere in the background, Refresh

Right click on the drive icon and rename your drive

  1. Then under Network/Storage

Right click on a drive and click install if you see that option.  If it says uninstall then uninstall and then reinstall.

Right click anywhere in the background and then Refresh

Go back to 1. and repeat until all drives have been installed and renamed.

If the drive doesn’t show up under Network/Storage, then access your drive through the web gui.  Then refresh under Network.

That seemed to work for me.