Windows Login failure on WD TV Live Hub

_ Which firmware? _


_ What happened? _

Starting yesterday (12/01/12), my WD TV Live Hub is unable to access the shared folder on my Win7-x64 box. This is due to a login failure resulting from an ‘invalid user name or password’ error that has suddenly started popping up on the WD unit.

I had not changed any settings either on the WD unit or my Win7-x64 PC recently and the last FW update was a while back (FW auto-update is enabled on the WD device).

_ What were you doing? _

Powered on the WD device (via Remote) to access some video on the shared folder on a Win7-x64 PC.

_ Does this happen every time? _

As of yesterday (12/01/2012).  It has since been consistent (100 % repro)

What hardware and media were you using?

Win7-x64 PC with a shared folder

_ Did this happen with previous firmware? _

I have encountered this issue a couple of times before, but cannot point to specific HW version. Nonetheless, a cold-boot (full power cycle) did fix it in the past.

_ Does power cycling the unit solve this? _

Not anymore.

_ Does resetting to factory defaults solve this? _

No (tried it multiple times, with and without a cold-boot after reset)

Have you tried this on other devices?

I have another non-WD media player that uses the *same* shared folder access mechanism (same Win7-x64 PC with the same username & password) but has never exibited this issue.  

Other Notes:

The WD device (and the other non-WD media-player device) use a special user account and password to login and access the shared folder on the Win7-x64 PC and I have not changed either of these since I’ve setup my WD device (about a year back)

The WD device and the Win7-x64 PC are on a HARD-WIRED (NOT WIRELESS) network.

I have verified the physical network connections and have ruled out all infrastructure issues.

I’ve tried the work-arounds mentioned in these forums and none have worked.

 I’d rather *not* roll back the FW to a previous version and am hoping for a less drastic  solution.  In any case, the current FW version was working until 12/01/12.

Please let me know if you folks need more info.


Umm… any WD tech support folks around? :slight_smile:

You dont really get Tech support from WD in here, this is just a community. At best it will get highlighted as in review.

I have these issues now and again, usually when I upgrade firmware, or recently when I got a new router etc…

Try unsharing the share, power down the Hub totally by holding power button for greater than 3 secs, then re-share the share again and power back up.

Maybe a router reset. Just had to do it here as the only devices connecting to the Hub in any way shape or form were Android devices. None of the PCs here, wired or wireless, could access it. Reset the cruddy 2wire AT&T U-Verse router did the trick.

Well strangely I got the same error myself today.

Was messing about big time with shares and a windows application and got the same error. Uninstalled the app and restarted Windows, then had to do a factory reset to get it to go away, but I think mine was self induced. Strange though why it would do that, think it may be more a Windows thing to be honest.

Thank you all, for your tips and suggestions… I did try pretty much all of these (multiple) times, before posting here.

Resetting the router does not apply/work for me.  As I’d mentioned in my original post, all devices are connected on a wired network over an commercial grade L2 backbone switch.

The WD unit has no issues getting on to the net (Netflix, Amazon Prime etc) but chokes only when trying to access the windows shares.  Also, as I’d mentioned in my original post, I do have another non-WD media player (Micca) in another room (on the same wired network segment) that has not had any issues with accessing the same shares.

Nevertheless, I did go ahead and try these (reboot, reset, unshare-reshare) all over again. 

Same results.

Micca (and the rest of the PCs) always login ok.  WD Live Hub just refuses to.

I’d sent an email to WD support as well but I have not heard back and it’s past the 24 hour response window they claim.


I guess I’ll just bite the bullet and sacrifice the weekend to build a HTPC.

Once again, many thanks to you all for your help and support.