Windows Explorer Access

Just setup my new WD My Cloud, connected everything ok, downloaded the software, updated the firmware, created shares… all good. Have got it up and running on my girlfriends Mac with no issues and on my Android phone, however on my Windows 8 laptop I cannot view it correctly in Windows Explorer.

In WD My Cloud Dashboard I setup my shares in the following way;

When I go to the WD My Cloud Software it looks fine;

However when I go to Windows Explorer I get this;

All folders are set with public access.

I have also tried mapping the drive and all I get is the same as shown in the above image.

How do I view my drive with Windows Explorer?

The easiest way is to  download wd discovery and it has an option to map all your shares (see if that works).


1 Like

Aside from that software being glitchy as **bleep** (guessing it is not compatible with Windows 8?), it worked!

When opening WD Discovery, the programm does not fit inside of the window size that it opens in and there is no way to expand or maximize the window. I tried playing around with different resolutions, nothing.

For anyone else out there having the same issues, after downloading and installing, just hit this;

Final result;

Thanks jamalaya!