Windows doesn't see MyBook Essential 3TB

We recently just bought a MyBook Essential 3TB external drive. We are having problems getting it to work. We’ve tried on 2 XP machines and 1 Windows 7 Machine. All three with the same result of it not showing up.

Under Windows 7:
It’ll show up in the disk management but when we try to initialize it, it keeps saying “Device not ready”, we’ve tried using both the MBR and other option when we initialize. It shows it under device manager working and it shows it under connected devices but not under Windows Explorer.

On both Windows XP machines:
It pops up that device is ready to use but it’s no where to be found. Not under disk management or windows explorer. It does show under the WD Smartware but it says it can’t find a usable partition. But I can’t find anywhere to format it, as its not recognizable under disk management.

There is no light on the front of it. User manual states a solid green light for standby. There isn’t any light on the front. Only light coming from it is a white light that you can see on the left looking at the back of it.

When we boot it up it makes no nose or movements. Feels like the drive is not spinning. Every other drive has some vibration which makes me think the drive is bad. We’ve tried plugging it straight into the wall outlet & into a surge protector. Same result with both. We’ve tried swapping out power cords, same results with both.

I believe the drive is bad but wanted to ask first.


EDIT: Also should add I did email WD Tech Support to see what they say, just figured posting here wouldn’t hurt either. LOL

I think the drive is faulty, take it back to the original place of purchase…