Windows cannot access \\WDMYCLOUD

Hi all,

I find that during large file transfers, my WD My Cloud disconnects, then cannot be seen on the network. It did it last night and its doing it again now.


I can access My Cloud via “WD My Cloud Dashboard”, however if I try to access it via windows, I get:

“Windows cannot access \WDMYCLOUD” and "\WDMYCLOUD is not accessible.

It seems the only way I can solve this each time is accessing “WD My Cloud Dashboard” and rebooting the device.

I have only had it 24 hours and it is using the latest firmware.

Has anybody had this problem and know a solution?


there are a few things you can try.

is your PC going to sleep? change the power settings for now so it dosn’t

set a static IP address, which includes the subnet mask, gateway & DNS addresses. the IP address needs to be outside the DHCP pool on your router. you can get the last 3 values on a Windows system by opening a command prompt and entering ipconfig /all

if your comfortable going into ssh you can disable the thumbnail process:

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable


Thanks for your advise.

I have tried setting a fixed IP address (.100), subnet and Default gateway.
The laptop is set not to go into sleep mode, I have even turned off power save on the network connections.

I have found tonight the same thing happens, even even deleting a large number of files in one go. I was deleting about 10GB of files, the MyCloud became un-accessible completely, no devices in my house could access it. I could only get in via the /UI, from there I could reset it and all is ok.

It’s the 3rd time this has happened, I am not having any luck…

A lot of users have reported the same issue. In many cases it is a transient issue when large and/or lots of files are uploaded to the NAS. This NAS is set up to do a lot of work with content (indexing, thumbnailing, etc) and it overpower the the other services like the file sharing service. You can either reboot the device or let it do its thing for several hours.

in my experiance rebooting is very temporary.

either wait or go in with SSH and at least run the 2 stop commands above, this will only stop them till the next reboot. also run the 2 disable commands if you don’t want them to re-start with the next reboot.